Cigarette lighter stopped working

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
Post Reply
OutdoorPlayer
Posts: 1
Joined: Mon Sep 12, 2016 12:53 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mits Delica
Location: Kelowna

Cigarette lighter stopped working

Post by OutdoorPlayer » Sun Aug 18, 2019 3:48 pm

FYI: my way on how to fix

A few months ago, the front cig lighter in my 96 Chamonix stopped working. Fuses were fine.
No power for my cell phone charger so I had to figure this out.

I finally took the panels off and used a Volt meter to find that the power connector had no contact to the front socket.
On closer look I see that there is a wire connecting the power source tab to the socket. That aluminium wire was no longer connected in the middle; maybe burned out like this was a last ditch heat fuse? Don't know.

Anyway, I soldered in Copper and it works great now.
I imagine you could take the bolt off and remove the spacer instead.

The line already has a fuse and I don't have the lighter (never will). So I feel okay about the fix.

If you think of any problems with this fix let me know.[IMG]https://uploads.tapatalk-cdn.com/201908 ... 239d52.jpg[/IMG]

Sent from my LG-H873 using Tapatalk


Lanky
Posts: 18
Joined: Sat Dec 10, 2016 10:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400 Shamonee
Location: Vancouver

Cigarette lighter stopped working

Post by Lanky » Sun Sep 01, 2019 9:19 am

Nice thanks for this mine has been gone for a while and havent bothered fixing it. Thanks for the info.

Post Reply

Return to “L400 Technical”