neutral safety switch and glow plugs

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
Post Reply
mblack
Posts: 18
Joined: Wed Sep 05, 2007 10:24 am

neutral safety switch and glow plugs

Post by mblack » Sat Dec 04, 2010 2:54 pm

Hello everyone,

Searched the archives but did not find an answer for this. Neither the glow plugs or starter are engaging when the key is turned on. I am trying to narrow down whether this is due to the neutral safety switch or ignition switch. There is noticeable resistance in teh shifter when moving between park and drive. Van will not start in neutral.

People with past neutral safety switch issues - do you remember if the glow plugs were cycling when the safety switch was malfunctioning? I.e. no starter AND no glow plugs, both of which were rectified when you cleaned up the NSS? Or for those of you with a functioning NSS, do the glow plugs work when the ignition is turned on with the transmission in gear?

I'm trying to narrow this issue down on the phone, since my wife is the one trying to figure this out while I am away. Any help is appreciated, so I can get the parts in the mail and hopefully have parts arrive by the time I return home.

Many thanks,
Matt

User avatar
patty
Posts: 713
Joined: Sat Jun 16, 2007 1:45 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: delica chamonix
Location: Whistler/Prince George

Re: neutral safety switch and glow plugs

Post by patty » Sat Dec 04, 2010 4:54 pm


mblack
Posts: 18
Joined: Wed Sep 05, 2007 10:24 am

Re: neutral safety switch and glow plugs

Post by mblack » Tue Dec 07, 2010 4:17 pm

Okay...thanks - seems simple enough. Was hoping someone knew if glow plugs cycle when ignition is turned on when vehicle is NOT in park or neutral - anyone?

RichD
Posts: 948
Joined: Mon Apr 19, 2010 6:05 pm

Re: neutral safety switch and glow plugs

Post by RichD » Tue Dec 07, 2010 5:10 pm

The resistance between Park and Neutral thing happened to me once. It turned out that cycling back into and out of 4WD fixed it, but that might be a causal fallacy as I only had the van a week or so at the time.

In my case, the van was on the whole time.
Richard Dagenais

Post Reply

Return to “L300 Technical”