Bad mileage, smoke, blah blah, suggestions?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
g_man1972
Posts: 111
Joined: Mon Sep 17, 2007 9:52 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 super exceed
Location: Vancouver

Bad mileage, smoke, blah blah, suggestions?

Post by g_man1972 » Wed Apr 16, 2008 3:49 pm

Hey everyone,

Trying to get a second, (or third, or fouth) opinion here. Problem with the Deli is mileage is pretty crummy, average I get 400km per 60l (fully city driving) give or take 10, seeing how others get around 500km and the current price of diesel, damn that adds up! And no matter how I drive her I get significant smoking. Sometimes I give gentle increasing pressure on the gas, no smoke till the turbo kicks in then WHAM the people behind start coughing:-). Or if I stomp on it a bit, like get it upto 1500rpm right off the bat, same thing. Also if I'm crusing at 40km and then speed up, there is a bit of a delay, like bogging down, then out comes the cloud of smoke with the power. I have taken it to CVI for a tune, which is timing, injector cleaning ect. already and while it does run smoother and starts easier no difference to the smoking. Last clue is that it happens when it's warmed up, I don't see anything till I've been driving for 10 minutes or so.

First opinion was that it's the injector pump and govenor sleeve, just wonding if it could be anything else before I commit to getting it done, something else? Anything cheaper ;-)

Thanks a bunch

User avatar
TardisDeli
Posts: 1420
Joined: Tue Sep 18, 2007 10:57 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300. 1997 L300.
Location: Burnaby
Location: Burnaby, Gaglardi freeway exit
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by TardisDeli » Wed Apr 16, 2008 4:59 pm

Definitely doesnt sound normal. I would say go back to CVI as they are very helpful, maybe something else needs fixing.

I have tried to get delica to smoke black, great for discouraging tailgaters. but sadly I can't.

When we have organized delica convoy trips, we are all watching each others delica's and comparing our rpm's and speed while driving using the radios, and only once did we notice anyone making smoke while driving, and that was just a momentary puff on a long hill (and it was a manual tranny in case yours is also). This includes freeway, country lanes, and off-road, in various weather conditions, from cold starts in the morning when group-camping to meets in town. So, no black smoke is usual.

I know when we first got ours, it smoked on starting but that was resolved when the slight leak in the fuel pump was corrected with the rebuild at cvi. Apparently is a problem when leaks, as is a pressurised system. The leak was barely noticeable, only around the pump, certainly not enough to drip to ground. We also got the injectors sonic cleaned to get out the gunge.

So maybe you have a leak somewhere else in the pressurized fuel system ??

Ask CVI to look, then you can decide if you want to fix it or live with it.

My mileage varies depending on my mood, grumpy days with idiots on road are very bad mileage as I tend to accelerate heavily. Mellow days are very good mileage.

Oh, check your tires !! That is huge fuel factor, easy fix. Read the rating on the tire, we found lots of people running about 30 to 35 psi, when rated for 50 (maybe should be closer to 40 for soft ride).

Is your alignment good ? Check the tire edges. I can drive with no hands on wheel and it stays in line.

Hmm, that's my initial ideas.
Christine.
Christine
Of The TardisDeli My TardisDeli travels thru time and space. Our house is nicknamed the TardisDeli Motel, as so many delii owners visit to share delii stories.

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by MardyDelica » Wed Apr 16, 2008 8:32 pm

Hi, sorry to hear that from you, just bring it back to cvi later next week & if i am there i will try to have a look & check, as edwin (mechanic) is coming back from vacation this sunday.
no problem well fix your problem. will try also to used diesel fuel additives which makes it less smoke & clean & lubricate the pump.
i used it for quite a while & its works for me very good.
maybe need to clean your egr as its maybe plug.
call cvi first & will try to help you.
cheers;
ImageImageImage

g_man1972
Posts: 111
Joined: Mon Sep 17, 2007 9:52 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 super exceed
Location: Vancouver

Re: Bad mileage, smoke, blah blah, suggestions?

Post by g_man1972 » Thu Apr 17, 2008 10:57 am

Thanks for the info. Judging from what you said, yes there is definately something wrong. When I was driving home last night and just going up the hill on knight street after the bridge heading north, I could see a bunch of smoke lit up by the headlights of the person behind me.

And Marty, thanks for the offer. I should state that I am not at all unhappy with the service I received, something else is wrong with it which isn't part of the normal Deli tune I guess.

Isn't it kind of strange that it only happens when it is warmed up? Never happens in the morning, only after about 10 minutes drive. And I notice that it seems to bog down (if thats the right term) more when it's warm as well. Hopefully that will help to narrow down whats wrong. Not being mechanical at all, but is there a sensor that adjusts the fuel flow based on the EGT, you know less fuel needed for a warmed up engine? Don't even know if fuel is regulated on a diesel, just thinking out loud.

User avatar
loki
Posts: 1428
Joined: Sun Dec 16, 2007 12:18 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 Delica Royal Exceed
Location: Victoria, BC

Re: Bad mileage, smoke, blah blah, suggestions?

Post by loki » Thu Apr 17, 2008 11:03 am

White or black smoke?

User avatar
JMK
Posts: 776
Joined: Thu Sep 20, 2007 8:42 pm
Vehicle: 92 Chamonix
Location: Rocky Mountains, Alberta, Canada

Re: Bad mileage, smoke, blah blah, suggestions?

Post by JMK » Thu Apr 17, 2008 11:10 am

The first thing you should turn your attention to would be the ECM. See this thread 'Fuel Economy':


I have the same problem you do and I'm hoping to get the time to pull the ECM later today.

Pull the ECM, take it apart anf visually inspect it. If you see and signs of blown resistors or capacitors either replace them yourself or take them to your neighbourhood geek or ham radio operator and ask them to do it. Will cost you a case of beer or a bottle of Scotch perhaps. Or, it is my understanding you could swap it out for a rebuilt unit from CCAutos for something like $150.00. This diagram was posted by Bruce on another related threadin this forum:

Image

Here's a more in depth look at the actual circuit board from the ECM in case you need it to show to your local repair geek to see if he would tackle it:
Image

User avatar
jwfchase
Posts: 508
Joined: Mon Dec 03, 2007 10:36 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '92 Super Exceed
Location: Kamloops, BC

Re: Bad mileage, smoke, blah blah, suggestions?

Post by jwfchase » Thu Apr 17, 2008 1:35 pm

I'm having identical symptoms to yours- even the "runs fine cold" and gets smokey and loses power once it warms up... I will keep my eye on this thread, please post it if you do find a solution!

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by MardyDelica » Thu Apr 17, 2008 6:15 pm

hi, there so many things to do when your deli has this problem.
we cannot talk about ecm again as it did on the last topic.
people has different ideas about this ecm. so we respect that.
as for me like i say before, this delica will run even without ecm.
you can put fabricated glow plug system & it will work & start its not electronic injection like toyota. i just dont want to go from there for now.
its a trade work that a mechanic & people who used to fix this delica will know the problem soon ,not just guessing ,for sure we can fix this problem, its a matter of understanding where this problem coming. as i fix many delica in the pass here in canada & back home in the phils. as there is tons of delica in the phils.
so many things to go wrong on this, we just have to remember we dont know what the previuos owner in japan did to the engine any modification or not.
so will just see, just bring it to cvi & will help you free of charge o.k.
well try our very best for your delica;
cheers;
ImageImageImage

User avatar
ccautos
Posts: 530
Joined: Fri Sep 15, 2006 11:25 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 Delica SE
Location: Coombs , BC
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by ccautos » Thu Apr 17, 2008 10:22 pm

Erm Mardy . please disconnect the two ECM connectors next time you are in a van . Does it still run ??? Maybe I`m missing something but isn`t the fuel shut off controlled by the ECM ??? If the computers not there how does it turn the fuel on ?? Or maybe you can mount several switches on your dash board . It would be like getting in a plane and turning on switch one for the fuel switch two for the glow plugs and then don`t forget switch three for the EGR that must only be operated at highway speeds when up to temp . Why not mount a forth switch for the starter but make it a push button and then you too can feel like a racing driver !!!!

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by MardyDelica » Thu Apr 17, 2008 11:05 pm

Hi, i do understand what you mean glen, but the egr is only control by vacuum.on this delica.
as hes problem is black smoke. as you see no wiring that control the injector like toyota attached to the board.
it has a connection for idle as this engine has coolant temperature sender its just goes from the injection pump.
as per my knowledge even this injection pump is not electronic, its a direct injection, the only thing it has is the idle sensor located on top of the pump even when your using the ac & when the engine warm up, then it feed from the board, not the amount of fuel it deliver thru the engine. whatever the pump pressure supply thats how it count to how much fuel goes to the injector & thru the engine. but if your egr is plug which is common to this mitsubishi delica & pajero, then its one of the symptom, just need to clean it for now & see what happen.
you see what i do is that do is step by step, as i am used to it with this engine back home.
you are also a mechanic & have your own way of doing it, if in a way it works for you & thats good. we just share our own idea but thru my experience i never touch this ecm module. as i consult mitsubishi mechanic in japan & dealer back home, if there is a connection they say no.
i have to relay on the dealer as there the one who has more knowledge about this module. we are just both sharing our experience.
too many thing like possible of fuel injection pump wrong setting, i mean setting inside injection pump not the injection timing its totally different. so maybe you can check that one also when time came if you need it.
i know you are good mechanic But we just have 2 different way of doing it, its just a trade for both of us.
if this delica has electronic injector then i would pressume something wrong with it.
but will see, as i never touch this ecm only when the glow plug resistor is gone.
it works for me. its a trade that we both have to learn which way to go.
like i say i wont go fo that now, but in later problem last resort then i might compare & see what the result.
hope this help both of us.
we just share both of our knowledge as for a good cause of being member of this club, which is very knowledgible by exchanging idea.
in the end we both gain knowledge.
cheers:
ImageImageImage

User avatar
ccautos
Posts: 530
Joined: Fri Sep 15, 2006 11:25 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 Delica SE
Location: Coombs , BC
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by ccautos » Thu Apr 17, 2008 11:27 pm

I have now diagnosed two black smoke issues with Delicas that after replacing injectors , rebuilding pumps , adjusting valve clearances , resetting injection timing and replacing all filters still had black smoke issues . The EGR is vaccum controlled but that vaccum control is governed by the vaccum solenoid at the back of the valve cover . This solenoid is operated by the ECM . What I have found with both vans is that the ECM was faulty in the control of the EGR and was causing black smoke . Both vans after replacement of the ECM had considerable reduction in smoking . I passed this information along to John @ Rocky Mountain Imports who also had `a smoker` with all tune up work done . After he replaced the ECM the van performed better and did not smoke . I have no doubt that there are many different theorys as to how to cure black smoke issues , I am just trying to pass on information gained from considerable experience with these vehicles .

Just thought of one other tip . I had another `smoker` that after carrying out the usual reconditioning work still had smoke on the highway . After many discussions with Action Injection in Nanaimo they asked how the transmission was . There was a slight `flare` between gear shifts that was noted on original inspection that was to be dealt at a later date . After replacing the transmission the smoke was gone , ran like a new one ...... not sure why but ???

User avatar
mdrive
Posts: 528
Joined: Tue Nov 07, 2006 3:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Location: Richmond, BC
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by mdrive » Fri Apr 18, 2008 2:39 am

FYI not all toyota run by EFI. Most acutally run by mechanical pump.
MardyDelica wrote:hi, there so many things to do when your deli has this problem.
we cannot talk about ecm again as it did on the last topic.
people has different ideas about this ecm. so we respect that.
as for me like i say before, this delica will run even without ecm.
you can put fabricated glow plug system & it will work & start its not electronic injection like toyota. i just dont want to go from there for now.
its a trade work that a mechanic & people who used to fix this delica will know the problem soon ,not just guessing ,for sure we can fix this problem, its a matter of understanding where this problem coming. as i fix many delica in the pass here in canada & back home in the phils. as there is tons of delica in the phils.
so many things to go wrong on this, we just have to remember we dont know what the previuos owner in japan did to the engine any modification or not.
so will just see, just bring it to cvi & will help you free of charge o.k.
well try our very best for your delica;
cheers;
Image
MAXIMUM OVERDRIVE AUTO IMPORTERS
4-7900 RIVER ROAD, RICHMOND, BC V6X1X7
TEL: 604-726-3109 Email: Sales@maxoverdrive.ca
For Vehicles visit: http://WWW.MAXOVERDRIVE.CA
For Online Parts Store, visit:http://www.maxoverdrive.ca/parts/.

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Bad mileage, smoke, blah blah, suggestions?

Post by MardyDelica » Fri Apr 18, 2008 6:46 am

Hi, i dont mean all toyota has electronic injection system,
the reason i say toyota has electronic injection is that i refer to most common car that canadian import such kind of vehicle like hi-lux surf, prado & landcruiser HDJ81.
other i agree that some toyota suv, cars & truck dont have electronic injection. as this is not new to me.
we have like this type of cars in the phils. toyota or mitsubishi lots & tons of diesel engine over there. as diesel engine is the primary engine they used. as we import many of this type of car back home from japan.
as japan is the primary source of cheap used engine , parts , car, truck & other related, to there need over there. as i work as a Shop supervisor back home with 6 mechanic, supervising all the job they do which is mostly diesel engine.that where i learn.
this is not new to me.
were just here to share our opinion thought & knowledge to help each other. 2 ,3 or more head is better than 1 head.
not picking whose the best to fix this vehicle, but to find solution how to fix it. there is always a learning process on all of this, always something new to learn as days goes by. people have different thought & opinion, thats what makes this delica club good & i respect that.
hope this clearout this issue.
cheers;
ImageImageImage

g_man1972
Posts: 111
Joined: Mon Sep 17, 2007 9:52 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 super exceed
Location: Vancouver

Re: Bad mileage, smoke, blah blah, suggestions?

Post by g_man1972 » Fri Apr 18, 2008 10:17 am

Lots of good info here, thanks all. FYI it's pretty thick black smoke, not white.

I think what I will do is have a look at the ECM just to see, as you suggested, if there is anything obviously broken or disconnected. Although I will be pretty much useless at fixing it, it will give me something to do. BTW how do you get access to it, just use a screwdriver to gently bend the plastic panel?

Mardy, I'll take you up on your offer some time during the week, I'll give you a call.

Gary
Last edited by g_man1972 on Fri Apr 18, 2008 10:18 am, edited 1 time in total.

User avatar
jwfchase
Posts: 508
Joined: Mon Dec 03, 2007 10:36 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '92 Super Exceed
Location: Kamloops, BC

Re: Bad mileage, smoke, blah blah, suggestions?

Post by jwfchase » Fri Apr 18, 2008 10:18 am

Now THIS is how a discussion should go! Differing opinions presented respectfully- AWESOME. I can't understand 1/2 of what you guys are talking about (not a mechanic) but this thread is still great to follow along with. Delica.ca as it should be... :-D :M :-D

Post Reply

Return to “L300 Technical”