Chamonix in the maritimes

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
Post Reply
User avatar
weelsey
Posts: 70
Joined: Mon Nov 13, 2017 5:36 pm
Member's Photo Album: http://www.delica.ca/Photos/profile.php?uid=15295
Vehicle: '90 2.5l high roof exceed
Location: Harvey Parish, NB

Chamonix in the maritimes

Post by weelsey » Tue Nov 12, 2019 7:27 pm

Hiya all, long time no see! I’ve acquired this '92 p34 recently. I'm looking into the claims it was running on (on its own) perhaps due to the turbo. It is oily there. But before tackling the td04 work, I’ve to determine if it’s had damage from hydro-lock and if this is why the starter will not crank it tho it will turn over by hand. with jumpering solenoid and using a good battery all I get is a “clunk”. It has a new starter and what tests to be a good starter that came off of it in the box. When turning on the crank by hand I don’t feel any considerable resistance. I checked my grounds and they seem fine. Could something have bent? Could a tourqe converter or tranny issue cause this do you suppose?

Scarily, when I put an additional battery in parallel with booster cables, it blew it’s top quite violently. Perhaps it’s just coincidence that the yard owner who had housed the van and looked into issues had had one of the two original batteries blow up on him, splitting its case. Weird, hey? Not sure what all I’ve gotten into and would love any of your thoughts and suggestions.

Anyone know what is this business under the driver seat? Do I have keyless entry? a transmission control module? Daytime running light business?

'hope everyone has been well enough and looking forward to chatting.
Vern
Attachments
IMG_3204.JPG
IMG_3204.JPG (159.12 KiB) Viewed 95 times
IMG_3205.JPG
IMG_3205.JPG (81.3 KiB) Viewed 95 times
IMG_3211.JPG
IMG_3211.JPG (105.94 KiB) Viewed 95 times
IMG_3212.JPG
IMG_3212.JPG (83.38 KiB) Viewed 95 times

Post Reply

Return to “L300 Technical”