Hard Startin Delica L300

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
Post Reply
philmeup1
Posts: 515
Joined: Wed Aug 22, 2012 6:20 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1992 Delica
Location: Ontario

Hard Startin Delica L300

Post by philmeup1 »

Hey folks, been a while since I’ve been on here. I have a ‘93 L300 that doesn’t get many miles put on it, even though it’s my primary vehicle.

Anyway, lately I’m having difficulty starting it up when it’s cold. I live just north of Toronto in Ontario, and usually it’s pretty good. But it went down to-10•C last night, and it was sputtering some for about 10 seconds before it finally smoothed out this morning. I’ve also noticed when it’s not very cold outside, it sometimes takes the engine to crank over several times before it catches. Usually it’s instantaneous.

It’s been a while since I’ve put new glow plugs and a fuel filter in it. I’m thinking I might try these simple things first. Does anyone else have any suggestions? It used to have a magnetic oil pan heater, but it fell off years ago. Perhaps another one of those would also help.

Any advice is appreciated. Thanks everyone ✌️

Phil
User avatar
deskinthewoods
Posts: 231
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

Re: Hard Startin Delica L300

Post by deskinthewoods »

Hey Phil! Glad to hear you still have your L300!

I'd bench test the glow plugs first for sure. I installed a bypass switch even though my controller still works (pre-emptive!) and on cold days I'll press that for a few seconds to even out the "chugging" after the glow plug controller does it's thing. I think I have one glow plug failing...

Cheers,
Alex in Wakefield, Qc
My dad used to say,"If you can read, you can do anything!"
philmeup1
Posts: 515
Joined: Wed Aug 22, 2012 6:20 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1992 Delica
Location: Ontario

Re: Hard Startin Delica L300

Post by philmeup1 »

Thanks for the reply. I don’t mind changing out the plugs. This thing owes me absolutely nothing as it’s been an incredible vehicle over my 10 years of ownership. I’m not all that technical, so I think I’ll start with this and perhaps a change of the fuel filter. I’ll post the outcome once I’ve had the work done. Hopefully it does the trick 🙏
Post Reply

Return to “L300 Technical”