L400 warm engine starting issues

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
Post Reply
claudiadh
Posts: 7
Joined: Thu Nov 10, 2016 8:57 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi Delica 1999
Location: Victoria

L400 warm engine starting issues

Post by claudiadh »

Hi,

We’re dealing with another mystery problem. Lately our 1999 Delica (l400/series2/diesel) is ok to start when cold, but the second and following starts are rough. Once it goes it’s fine, no problems driving, although I find the idle rougher than usual and it seems it’s even worse when the AC is turned on. The hotter the engine the harder it is to start. Minor white smoke coming out of exhaust. This issue is progressively getting worse so I’m concerned about driving it long distances.

None of local mechanics (Coombs/Rocky Mountain) are familiar with this issue, think it might be something with fuel injection/pressure.

We’ve had head casket seal and solenoids replaced past few years, fuel filters were cleaned less than two years ago and we use conditioner.

Any thoughts? Thanks so much
poochike
Posts: 180
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Re: L400 warm engine starting issues

Post by poochike »

That's a tough one. Sounds a bit like air in the lines. If your injectors were needing serviced you'd most likely have black smoke and diesel knock. Could be yiu injection pump, but thats an expensive ghost to chase. Better to know it's the pump for sure before pulling it. Your a/c will bump up your idle a bit so if you're having rough idle issues it would make them worse in theory. Is the white smoke always or just at start up? I had a constant white/greyish smoke forever and I replaced the pump, problem solved (also a 99 series 2). You've blanked your egr?

It does sound like a fuel delivery issue though. Wish I could be of more help.
claudiadh
Posts: 7
Joined: Thu Nov 10, 2016 8:57 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi Delica 1999
Location: Victoria

Re: L400 warm engine starting issues

Post by claudiadh »

Thanks for your reply :) white smoke comes on after a few rough starts, as mentioned the more stops the tougher the starts get. I’ll have to check with Rising Sun about egr, we never did anything with it.
Post Reply

Return to “L400 Technical”