Buzzing under the hood

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
Post Reply
mdevelden
Posts: 11
Joined: Tue Nov 14, 2017 12:48 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Vera, '99 Chamonix, PE8W
Location: Delta, BC

Buzzing under the hood

Post by mdevelden » Mon Jan 14, 2019 6:48 am

Vera, my new to me '99 Chamonix PE8W, has an issue. When I turn the ignition on to warm the glow plugs I hear a buzzing from under the hood on the right side of the engine block. I can't hear it while the engine is running but that may be cause the engine is running. When I turn the engine off I hear the buzzing again for about three seconds and then it stops.
To me it sounds like a relay chattering but I cannot locate the relay. As per another post I checked the batteries and they are good.
Any ideas?

saltypeanuts
Posts: 9
Joined: Sun Oct 22, 2017 1:19 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400 Series 2
Location: Calgary AB

Buzzing under the hood

Post by saltypeanuts » Mon Jan 14, 2019 3:07 pm

I have the same noise. I think it has to do with the glow plug circuit - I wired a light and switch to mine so I can see and control when it is on. The buzzing is only when the glow plugs run in my car. If you put a multimeter to the glow plug contactor bar or relay you should be able to verify this.

mdevelden
Posts: 11
Joined: Tue Nov 14, 2017 12:48 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Vera, '99 Chamonix, PE8W
Location: Delta, BC

Buzzing under the hood

Post by mdevelden » Tue Jan 15, 2019 6:55 am

I already checked and it is not the actual glowplug relay that is right at the battery. It is coming from further down in the engine bay beside the engine block. Its into the mechanic now for import upgrades and I am going to get him to take a look at it. Thanks.

Post Reply

Return to “L400 Technical”