Rear hatch interior light sensor

Topics may eventually be moved to other Delica Canada forums.

Moderators: BCDelica, mark

Post Reply
Kamelion
Posts: 1
Joined: Sat Jan 19, 2019 12:04 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica L400
Location: Nelson, BC

Rear hatch interior light sensor

Post by Kamelion » Sat Jan 19, 2019 1:48 pm

Hi guys, i am new here. Just purshased a 97 delica L400 and so far so good considering its age...

I am experiencing some technical difficulties with the door sensor pins/switches. I have I blinking open door light in the dash and the rear interior light doesn't come on when the door is open...

I was able to find new door pins/switches for the front but I have no idea where the rear hatch sensor is located. And there are no door pin or switch anywhere visible.

Anyone run into the same issue or know how to deal with this?

Many thanks!

User avatar
Growlerbearnz
Posts: 2011
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

Rear hatch interior light sensor

Post by Growlerbearnz » Sun Jan 20, 2019 1:47 am

On the L300 the switch is part of the latch mechanism.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

volnoir
Posts: 48
Joined: Mon Dec 03, 2012 11:34 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 95 L400 Super Exceed
Location: Vancouver

Rear hatch interior light sensor

Post by volnoir » Mon Jan 21, 2019 12:35 pm

Mine does that too. Sometimes it turns on. Would love to hear how to troubleshoot it!

Khrolar
Posts: 58
Joined: Thu Aug 09, 2018 4:27 pm
Member's Photo Album: http://www.delica.ca/Photos/VD
Vehicle: 1994 L400, LWB, Super Exceed
Location: Victoria

Rear hatch interior light sensor

Post by Khrolar » Mon Jan 21, 2019 8:31 pm

I believe I have a similar issue, on my 94 L400 the rear light and middle light do not come on when opening the rear hatch. Sometimes they flicker but normally I get nothing. All lights work with the other doors.

Let's see what we can figure out guys!

As Growlerbeans said, I believe the switch is part of the latch mechanism. I have not found any other pressure switches in my investigation so far

thelazygreenfox
Posts: 860
Joined: Tue Jun 08, 2010 7:21 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 99 white Hi roof gas Chamonix
Location: Coquitlam B.C.
Location: coquitlam canada

Rear hatch interior light sensor

Post by thelazygreenfox » Tue Jan 29, 2019 10:27 am

Same problem here.

Try working the switches back and forth. It cures the problem temporarily in my van.

It's a winter or damp air problem. It'll clear up when the daylight increases and you don't need the interior lights anymore. PITA

There's lots of 12 volt corrosion problem on deli switches and connections.
MD :-D :-D
I've been a lazy brown, green and white fox. :M Moby Dick isn't lazy anymore but what's a "Dick?" :-D

knet109
Posts: 8
Joined: Sat Jun 30, 2018 9:02 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 97 L400 S1 Jasper
Location: Mission, BC
Contact:

Rear hatch interior light sensor

Post by knet109 » Wed Feb 06, 2019 8:20 pm

'97 L400 Jasper. I have the cover off my door at the moment. Will take a look in the daylight. License plate light sockets completely rusted out and rear door mechanism needed a bath in Liquid Wrench. Opens great now but when I brake at a stop, the door open light is coming on. Not sure about the lights working or not so I will check that too.

Khrolar
Posts: 58
Joined: Thu Aug 09, 2018 4:27 pm
Member's Photo Album: http://www.delica.ca/Photos/VD
Vehicle: 1994 L400, LWB, Super Exceed
Location: Victoria

Rear hatch interior light sensor

Post by Khrolar » Tue Feb 12, 2019 8:35 pm

I sprayed some lithium grease in the back lock over the weekend. It seems to have sorted my problem out. But now the lights won't work with the side door. :-(

volnoir
Posts: 48
Joined: Mon Dec 03, 2012 11:34 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 95 L400 Super Exceed
Location: Vancouver

Rear hatch interior light sensor

Post by volnoir » Wed May 22, 2019 7:46 am

Any other solutions found for this? Mine is flickering on and off and I always have to be sure when I leave my van that the back light isn't accidentally on.

Khrolar
Posts: 58
Joined: Thu Aug 09, 2018 4:27 pm
Member's Photo Album: http://www.delica.ca/Photos/VD
Vehicle: 1994 L400, LWB, Super Exceed
Location: Victoria

Rear hatch interior light sensor

Post by Khrolar » Wed May 22, 2019 8:43 am

So I had the pleasure of swapping out my tailgate after smashing the glass in it. During this I took a very good look at the rear latch mechanism.
Inside the tailgate there is a single neutral wire that Runs down to the latch mechanism.
When the latch and the tailgate are open a grounding connection is made via the left bolt on the latch. It's the one without the washer. Removing this bolt, cleaning it up, and re tapping the hole in the tailgate may help the ground connection if it got weak.
Unfortunately the latch mechanism is unable to be completely disassembled to be cleaned. I used a screw driver to engage and disengage the latch mechanism and a wire brush + Rag to clean as much crap as I could out of it. Soaking the latch mechanism in some degreaser would also help. Then as others have done use some white lithium grease inside it and work it into the latch.
IMG_20190506_171449_compress99.jpg
IMG_20190506_171449_compress99.jpg (112.54 KiB) Viewed 581 times
IMG_20190506_165459_compress81.jpg
IMG_20190506_165459_compress81.jpg (196.47 KiB) Viewed 581 times
It turns out my lighting problem was coming from the circuit board that controls the middle light. Currently I'm searching for a way to make it LED, but not having much luck.
Also the rear most light bulb was shot, despite looking perfectly fine. :-(

thelazygreenfox
Posts: 860
Joined: Tue Jun 08, 2010 7:21 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 99 white Hi roof gas Chamonix
Location: Coquitlam B.C.
Location: coquitlam canada

Rear hatch interior light sensor

Post by thelazygreenfox » Wed May 22, 2019 11:25 am

Led lights in the same bulb shape are available out of China. Make 100% sure to order the correct metric length, I had to reorder after the company sent the wrong length.

While you have the tailgate apart.... run a cable across from the opening mechanism to the passenger side inspection flap with a loop on it. You can use this to (pull) open the tailgate from the inside. Always been one of my complaints about the L400 that you couldn't open the tailgate from the inside so I built an opener this way. Good safety item if you need get out in a hurry.

Have fun
MD :-D :-D
I've been a lazy brown, green and white fox. :M Moby Dick isn't lazy anymore but what's a "Dick?" :-D

demiro
Posts: 29
Joined: Mon Apr 02, 2018 6:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica
Location: winnepeg

Rear hatch interior light sensor

Post by demiro » Thu May 30, 2019 10:39 pm

Do you still remember the name of the seller where you ordered your LED lights?

Khrolar
Posts: 58
Joined: Thu Aug 09, 2018 4:27 pm
Member's Photo Album: http://www.delica.ca/Photos/VD
Vehicle: 1994 L400, LWB, Super Exceed
Location: Victoria

Rear hatch interior light sensor

Post by Khrolar » Fri May 31, 2019 6:07 am

eBay or Amazon. :-D

Post Reply

Return to “General Discussion”