What did you do TO your Delica today?

Topics may eventually be moved to other Delica Canada forums.

Moderators: BCDelica, mark

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Sat Jun 23, 2018 10:54 am

A couple weeks ago I got the front cowling and fog lights reinstalled...
Wilson.jpg
Wilson.jpg (84.19 KiB) Viewed 257 times


I removed the "Mitsubishi" and insterted "Wilson" because, you know, I can...

and ...
Tonka.jpg
Tonka.jpg (49.19 KiB) Viewed 257 times


because my neighbour said, "you should put "Tonka" on that...so...i did! :-D

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Sat Jun 23, 2018 2:44 pm

So, um,...anybody need one of these?
EGR.jpg
EGR.jpg (46.26 KiB) Viewed 250 times

User avatar
Growlerbearnz
Posts: 1778
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

What did you do TO your Delica today?

Postby Growlerbearnz » Sun Jun 24, 2018 7:41 pm

DKUR9Tk copy.JPG
DKUR9Tk copy.JPG (22.73 KiB) Viewed 239 times
Nothing says "poor workmanship" more than wrinkles in the duct tape.

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Mon Jun 25, 2018 5:29 am

Shame, really. Such a pretty bit of engineering...

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Mon Jun 25, 2018 1:37 pm

Gauges!!!
Gauges.jpg
Gauges.jpg (30.67 KiB) Viewed 225 times

Turbo Boost on the left; reads 12PSI on the test drive, and, Exhaust Temperature on the right; reading around 350C on the short test drive.
(what should the temperature be at cruising speed once warmed up on a nice summer day of 23C?)

[I just noticed the date and time need setting on the stereo :P]

User avatar
Growlerbearnz
Posts: 1778
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

What did you do TO your Delica today?

Postby Growlerbearnz » Mon Jun 25, 2018 2:44 pm

400-550c at 100kph is normal, try and limit it to 650C when climbing a hill, 700C is ok for short periods (eg. overtaking).
Nothing says "poor workmanship" more than wrinkles in the duct tape.

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Mon Jun 25, 2018 5:38 pm

Thanks, again...

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Sun Jul 01, 2018 10:06 am

Yesterday I refilled the AC. I got the Princess Auto kit, put in oil, dryer, and system seal (I know someone recommended not putting it in but...)
Added the coolant and... COLD AIR!!! :-D

Took a while to find the ports, especially the low port, which is not on the pipe but actually seems to be on the compressor (91 L300)

AC ports.jpg
AC ports.jpg (58.38 KiB) Viewed 163 times


Also found these under the front...are they for the rear AC to tie into if you have rear AC?
mystery ports.jpg
mystery ports.jpg (56.05 KiB) Viewed 163 times


33C today (Happy Canada Day!) and the AC still working...

User avatar
Growlerbearnz
Posts: 1778
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

What did you do TO your Delica today?

Postby Growlerbearnz » Sat Jul 14, 2018 3:44 am

Those ones are for the front cool box/ice maker. :-)
Nothing says "poor workmanship" more than wrinkles in the duct tape.

User avatar
Growlerbearnz
Posts: 1778
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

What did you do TO your Delica today?

Postby Growlerbearnz » Sat Jul 14, 2018 3:49 am

Replaced the front wheel bearings. Again. That "Premium quality high temperature wheel bearing grease" that was surprisingly cheap? Yeah, it didn't do a great job. Overheating bearings. Ugh.
IMG_20180714_153738 copy.JPG
IMG_20180714_153738 copy.JPG (44.56 KiB) Viewed 70 times

IMG_20180714_152856.jpg
IMG_20180714_152856.jpg (55.11 KiB) Viewed 70 times


So now we have lovely Redline CV-2 synthetic grease and genuine oil seals (the non-genuine ones I had before had very stiff flaps, and seemed to be worn away)
IMG_20180714_162107.jpg
IMG_20180714_162107.jpg (59.22 KiB) Viewed 70 times


Though I'd forgotten just how much grease there is in the front hubs. Wheel bearings, locking hubs, driveshaft needle rollers... that's a lot of cleaning and reassembly.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Sat Jul 14, 2018 6:09 pm

Well, that looks down right pretty!

Today I tracked down a vacuum leak...actually I think a boost leak. The hose had split just at the clamp so I cut it off at the split and put it back on.
Vacuum leak.JPG
Vacuum leak.JPG (60.38 KiB) Viewed 53 times


I'll order a new hose but in the meantime this should do...I hope.

Power is back!

[edit: any idea of the part number for this hose?

and again: vacuum leak, nothing to do with boost]

User avatar
deskinthewoods
Posts: 39
Joined: Thu Mar 08, 2018 10:35 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300 Star Wagon named "Wilson"
Location: Wakefield, Québec

What did you do TO your Delica today?

Postby deskinthewoods » Tue Jul 17, 2018 2:40 pm

Changed the transmission oil, transfer case oil and rear differential sludge...might have been original...

Somehow I forgot to get oil for the front axle...don't judge me, I'm new to all this :shock:

204explorer
Posts: 157
Joined: Sun Oct 02, 2016 10:19 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: CA

What did you do TO your Delica today?

Postby 204explorer » Wed Jul 18, 2018 6:10 pm

Thats why I started buying oil by the pail. Less likely to run out.

Sent from my SM-G950W using Tapatalk


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 11 guests