L400 V6 (6G72) Exhaust / Tuning Question

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
sinjin
Posts: 29
Joined: Wed Aug 03, 2016 7:16 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 96 Delica L400 V6 LWB Super Exceed
Location: British Columbia

L400 V6 (6G72) Exhaust / Tuning Question

Postby sinjin » Mon Jun 11, 2018 12:27 pm

Im a proud owner of a 96 L400 S1 LWB V6 (6G72). I'd like to know what I NEED to do, at a minimum, to replace the exhaust, or portions of the exhaust system. I know there are sensors in the exhaust system, potentially pre-and-post catalytic converter? Can anyone confirm? Is it possible to remove the cat in this system and not affect things adversely?

I'm getting some stuttering at a certain rpm range, noticeable around 2000 rpm on a bit of an uphill (say around 60 km/hr). If I push the rpms higher, or drop them, the stuttering stops. Also, it seems it does stutter a bit if I start the engine up shortly after a recent drive (engine still hot), but normally corrects itself pretty quickly. I believe I have an exhaust leak, or maybe clogged cat. So I want to address the exhaust issues before I look at tuning, and things like plugs and wires etc.

Any tips or advice would be welcomed.

thelazygreenfox
Posts: 817
Joined: Tue Jun 08, 2010 7:21 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 99 white Hi roof gas Chamonix
Location: Coquitlam B.C.
Location: coquitlam canada

L400 V6 (6G72) Exhaust / Tuning Question

Postby thelazygreenfox » Fri Jul 13, 2018 6:17 pm

search catalytic convertor. I put in a post in about cleaning out your cat. Or better still replace it, check out Rockauto for replacements. Of course it's illegal and dangerous with all the carbon monoxide and aldehydes a gas engine creates so I can't recommend running without a cat.

It's easy to remove and replace but the gaskets break easy so be careful with those. Also lube the bolts so they don't break on you.

Changing plugs is a pita so is cleaning the butterfly in the air inlet but do both if you change plugs. The plugs last a long time so I wouldn't jump to change them except as a last resort.

By your description I'd say exhaust is the culprit, same issues as I had 2 years ago.

viewtopic.php?f=64&t=16485&p=125046&hilit=catalytic+converter#p125046

Good luck
I've been a lazy brown, green and white fox. :M Moby Dick isn't lazy anymore but what's a "Dick?" :-D


Return to “L400 Technical”

Who is online

Users browsing this forum: No registered users and 6 guests