Squeaky Belts

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
manitoba
Posts: 28
Joined: Mon Aug 21, 2017 8:06 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: winnipeg

Squeaky Belts

Postby manitoba » Tue Jan 16, 2018 5:58 pm

Advice needed! 3L V6 petro engine. Had all three belts replaced by my mechanic shortly after I got the van in Nov ‘17. It would squeal at take off or turning a corner. Problem solved until the deep freeze of Manitoba set it. -30°C started squealing again. Problem has got worse even after I took it back to the shop to get things adjusted. I was told the power steering belt was tightened but otherwise they thought maybe the battery was drained during start up and the draw on the alternator was causing the issue. I’m going to take it back again but wanted to check to see what everyone’s experience is. Thanks!


Sent from my iPhone using Tapatalk

User avatar
bitnaut
Posts: 30
Joined: Thu Nov 17, 2016 7:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 Royal Exceed PD6W
Location: Vancouver
Contact:

Squeaky Belts

Postby bitnaut » Tue Jan 16, 2018 9:08 pm

Sometimes it could be the harmonic balancer that needs to be replaced...that’s what happened with my V6 petrol Delica when I had squealing belts even after replacing them.

manitoba
Posts: 28
Joined: Mon Aug 21, 2017 8:06 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: winnipeg

Squeaky Belts

Postby manitoba » Tue Jan 16, 2018 10:32 pm

Thanks for the input / I’ll check into that!


Sent from my iPhone using Tapatalk

Thomasdontgiveacrap
Posts: 15
Joined: Wed Dec 07, 2016 7:37 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400 Chamonix
Location: Calgary

Squeaky Belts

Postby Thomasdontgiveacrap » Wed Jan 17, 2018 5:42 pm

Hey, sometimes power steering pump makes kind of "bad bearing" sound and pump is right there. Especially if you have leak in PS or running low on PS fluid. I have same model and honestly, below -25 my fan belts get noisy before she warms up. If you have been told that your belts and bearings are fine, it should be something else.
[I was going thru this last winter. Worried about belts but it turned out to be leak in PS. That pump can be noisy as hell if you running low PSF] Easy to check.

manitoba
Posts: 28
Joined: Mon Aug 21, 2017 8:06 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: winnipeg

Squeaky Belts

Postby manitoba » Wed Jan 17, 2018 5:48 pm

Thomasdontgiveacrap wrote:Hey, sometimes power steering pump makes kind of "bad bearing" sound and pump is right there. Especially if you have leak in PS or running low on PS fluid. I have same model and honestly, below -25 my fan belts get noisy before she warms up. If you have been told that your belts and bearings are fine, it should be something else.
[I was going thru this last winter. Worried about belts but it turned out to be leak in PS. That pump can be noisy as hell if you running low PSF] Easy to check.

Thanks for the input! I’ll check that for sure. Today was -3C and it only chirped a couple times. Crazy weather we’ve been having


Sent from my iPhone using Tapatalk

Ralph in Winnipeg
Posts: 158
Joined: Wed Sep 02, 2015 7:42 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94 Strada
Location: Winnipeg

Squeaky Belts

Postby Ralph in Winnipeg » Thu Jan 18, 2018 7:42 am

I have heard/read about belts squeaking because the pulleys are not perfectly aligned. Pulleys can be shimmed to bring them into better alignment. My Daihatsu Hijet belts squeak and I spray a little WD40 on the pulleys every once in a while. The belts are tight enough not to slip, the lubrication just helps the belt fit into the pulley groove without rubbing and squeaking. I remember spraying "belt dressing" on the belts and pulleys of combines and other farm machinery as a kid for the same reason. It's worth a try! Ralph in Winnipeg

manitoba
Posts: 28
Joined: Mon Aug 21, 2017 8:06 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: winnipeg

Squeaky Belts

Postby manitoba » Thu Jan 18, 2018 7:55 am

I’ll check that too Ralph thanks! I saw a YouTube vid yesterday talking about misaligned pulleys. Hope it’s not the Harmonic Balancer...


Sent from my iPhone using Tapatalk


Return to “L400 Technical”

Who is online

Users browsing this forum: No registered users and 3 guests