Oil Leak from Vacuum Pump

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
sfd_656
Posts: 89
Joined: Mon Oct 24, 2011 12:33 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: kamloops

Oil Leak from Vacuum Pump

Postby sfd_656 » Thu Nov 02, 2017 10:07 pm

Our 1996 l400 recently sprang a leak from what i think is the vacuum pump (passenger side of the engine compartment on the front of the motor with a line running to the brake booster). It appears that the top piece is broken off? Does anybody have any insight? What is the black plastic part that looks broken? Is the pump rebuild-able with some o rings?
Thanks
vac pump com.jpg
vacuum pump
vac pump com.jpg (12 KiB) Viewed 135 times
vac pump 2 com.jpg
vac pump 2 com.jpg (12.26 KiB) Viewed 135 times
vac pump comst.jpg
vac pump comst.jpg (8.04 KiB) Viewed 134 times

poochike
Posts: 63
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Oil Leak from Vacuum Pump

Postby poochike » Fri Nov 03, 2017 9:57 pm

sfd_656 wrote:Our 1996 l400 recently sprang a leak from what i think is the vacuum pump (passenger side of the engine compartment on the front of the motor with a line running to the brake booster). It appears that the top piece is broken off? Does anybody have any insight? What is the black plastic part that looks broken? Is the pump rebuild-able with some o rings?
Thanks
vac pump com.jpg
vac pump 2 com.jpg
vac pump comst.jpg
I'm pretty sure that's your oil pressure sender. Common problem, easy fix. CVI, RJD, Amazing Auto, Rising Sun, Coombs Country Auto will all have the part. About $20 if I remember correctly. I carry a spare with me just in case.

Sent from my SM-G920W8 using Tapatalk

sfd_656
Posts: 89
Joined: Mon Oct 24, 2011 12:33 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: kamloops

Oil Leak from Vacuum Pump

Postby sfd_656 » Sat Nov 04, 2017 10:03 pm

Thank you, does the fix just involve removing the old sender and threading in the new one and reattaching the wire? What causes them to break? I have the new part on the way.

poochike
Posts: 63
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Oil Leak from Vacuum Pump

Postby poochike » Sun Nov 05, 2017 7:13 pm

sfd_656 wrote:Thank you, does the fix just involve removing the old sender and threading in the new one and reattaching the wire? What causes them to break? I have the new part on the way.
That's it. Believe it's a 22mm deep socket or a small adjustable wrench to remove the old one. They're just a weak point in the system. Usually the wire connection doesn't bust off, it just leaks from the top. Maybe yours was bumped from some recent work to cause the wire connection to bust off? There's a through bolt underneath that attaches to the banjo. If this comes out with the oil sender be careful not to lose the 2 copper washers.

Sent from my SM-G920W8 using Tapatalk

sfd_656
Posts: 89
Joined: Mon Oct 24, 2011 12:33 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: kamloops

Oil Leak from Vacuum Pump

Postby sfd_656 » Mon Nov 06, 2017 12:08 am

Thanks again.

poochike
Posts: 63
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Oil Leak from Vacuum Pump

Postby poochike » Wed Nov 08, 2017 5:10 pm

sfd_656 wrote:Thanks again.
You get things sorted?

Sent from my SM-G920W8 using Tapatalk

sfd_656
Posts: 89
Joined: Mon Oct 24, 2011 12:33 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: kamloops

Oil Leak from Vacuum Pump

Postby sfd_656 » Wed Nov 08, 2017 5:27 pm

Parts just arrived and getting dark outside will have to wait until friday. Old sensor needs a 1 1/8" deep socket (will have to borrow one, new one from mardy fits in a 24mm deep socket

sfd_656
Posts: 89
Joined: Mon Oct 24, 2011 12:33 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: kamloops

Oil Leak from Vacuum Pump

Postby sfd_656 » Fri Nov 10, 2017 3:20 pm

All done, leak is cured.

poochike
Posts: 63
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Oil Leak from Vacuum Pump

Postby poochike » Sat Nov 11, 2017 3:17 pm

sfd_656 wrote:All done, leak is cured.
Nice one.

Sent from my SM-G920W8 using Tapatalk


Return to “L400 Technical”

Who is online

Users browsing this forum: No registered users and 3 guests