A/C not working - a leak in rear condenser

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
Lukas
Posts: 3
Joined: Tue Aug 08, 2017 11:28 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 L400
Location: Vancouver

A/C not working - a leak in rear condenser

Postby Lukas » Tue Aug 08, 2017 11:43 pm

Hello guys, I had my 1994 Delica in the shop today - the A/C is not working, both front and rear. I was told there is a leak in the rear condenser which has to be replaced. I read some forums when I got home and apparently the rear condenser is supposed to be just for the rear seats A/C and front condenser for the driver and passenger. So replacing this part would only fix the rear A/C and there must be another issue with the front. Is that correct ? Thanks for answers.

izack98
Posts: 130
Joined: Tue Apr 30, 2013 4:15 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1997 L400 Super Exceed PE8W
Location: Delta B.C.

A/C not working - a leak in rear condenser

Postby izack98 » Wed Aug 09, 2017 2:21 am

There are two condensers, one front, one rear. They are 'fed' from the same compressor. If you have a leak in the rear, it drains the entire system.

Where did you take your van to get the A/C worked on? I need mine checked and recharged.

Lukas
Posts: 3
Joined: Tue Aug 08, 2017 11:28 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 L400
Location: Vancouver

A/C not working - a leak in rear condenser

Postby Lukas » Wed Aug 09, 2017 10:32 am

Hi, thanks for the answer. I went to Loyal auto repair in Coquitlam on Lougheed Hwy.


Return to “L400 Technical”

Who is online

Users browsing this forum: No registered users and 4 guests