Van trouble in Calgary

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 8:02 pm

Well, the engine oil was low, but not very low.

I realized that all of the problems started just after I filled up at a truck stop in Strathmore because I was almost out of fuel.
I wonder if it is possible that the problem is in the last fillup. It was a Husky station, but not a particularly busy one.

I have half a tank of fuel left from there. I wonder if I should top it up and see if the problems diminish somewhat.

I will call around tomorrow and see if I can find somewhere I can get a new fuel filter.

On my last ride around the neighbourhood I noticed that when I tried to accelerate, there was a hesitation,then knocking in the front end followed by a big cloud of white smoke, then the knocking diminished and power returned. It seems to run pretty well at higher speeds, but when I stop or slow down the whole pattern just repeated.

The van starts fine. No problem there.

I can fix just about any problem on a bicycle, but really feel like a tool around this engine.

Many thanks for the replies.

mac_stang
Posts: 184
Joined: Mon Sep 06, 2010 1:45 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94' L400
Location: Cloverdale B.C.
Location: Cloverdale B.C.

Re: Van trouble in Calgary

Post by mac_stang » Wed Jul 20, 2011 8:29 pm

sounds like changing the fuel filter is the best place to start, you should go to the nearest heavy duty parts store(big rig and bus stuff) and get some "howes" fuel stabilizer...really keeps your disel fuel in top form.

Good luck Patton,

Brad.

foxycanuck
Posts: 82
Joined: Tue Jan 04, 2011 11:48 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica L400
Location: Calgary

Re: Van trouble in Calgary

Post by foxycanuck » Wed Jul 20, 2011 8:50 pm

There's another shop in Okotoks called Hilltop Shell (I think they answer the phone OK tire or something like that). Shane (the owner) is an honest guy and has worked on our Delica before. He can diagnose Diesel engines, although you may be on your own sourcing parts (same as Kirkham).

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Van trouble in Calgary

Post by MardyDelica » Wed Jul 20, 2011 9:49 pm

hi, patton,
this is a simple problem.
pls dont let any diesel mechanic in your area do the work on your van for now:
its all fine did extensive service on your van before i sold to you.
your van is ok but, just try to block your egr valve.
do this one first.
then now try to push the top botton of the fuel filter until it feels hard to push maybe you have some air.
did happen to some of my customer when they fill up very low on fuel.
as the fuel filter for this L400 is in high position. higher than the injection pump.
so sometime it happen like this.
also chekc if you fill up 100% diesel not gas.
did have customer also have this problem but unfortunately she did put gasoline insteed of diesel
so make sure your fill up the fuel on half tank all the time
to avoid this problem.
did clean and pre test pressurized your injector.
try to call me tomorrow and will help you on this.
this is just a simple one not big. dont need to do injection pump and injector your fine:
604-720-6144
cheers;
mardy
ImageImageImage

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Thu Jul 21, 2011 7:46 am

Thanks Mardy,

I'm a bit relieved to hear that it's not serious. I'm not sure how to block the EGR valve or find the fuel filter :oops: but I will call you this afternoon to see if you can walk me through this.

If there's a Calgary Delica owner who could help me with this fix I'd be happy to pay for time etc. I also have a Friday night pass for the folk festival this weekend that I'd be happy to give to anyone who could help a brother out.

Cheers,

Patton

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Van trouble in Calgary

Post by MardyDelica » Thu Jul 21, 2011 11:50 am

your welcome my friend,
anytime just call me
Cheers;
mardy
ImageImageImage

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Thu Jul 21, 2011 1:30 pm

Thanks Mardy.

I'm running off to the folk festival for the day to get back to my holiday! But I ewill call you soon to get a walkthrough.

Cheers,

Patton

madmazda
Posts: 460
Joined: Mon Nov 10, 2008 2:03 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 l400
Location: calgary Alberta

Re: Van trouble in Calgary

Post by madmazda » Thu Jul 21, 2011 3:50 pm

i was planning on blanking my egr as well and do a filter change this weekend. I would have taken you up on the folk fest ticket as i really wanted to go but am silly busy :-( if i have a second i might be able to point you in the right direction.... :-D

User avatar
naterade
Posts: 223
Joined: Mon Aug 16, 2010 10:05 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 93 L300 Starwagon Exceed
Location: Nelson BC
Location: Nelson BC

Re: Van trouble in Calgary

Post by naterade » Fri Jul 22, 2011 6:26 am

You mentioned the problems started since your last fill up....

I have been slightly paranoid filling up my van in rural Alberta since my experience with a co-worker filling his diesel work truck in Three Hills a few years ago- one day his truck lost power, blew smoke, and had to go to the shop. When they checked the fuel in his tank, it was almost half water - the underground diesel tank at the fueling station had accumulated a lot of water over time. He showed me a sample of what the mechanic took from the tank.... ugly stuff :o

I wonder if this may be the case? Do the L400s have a 'water in the fuel' warning light like the L300s?

Anyways, just adding to the brainstorming :-D I hope you get everything sorted and your van back on the road.


Cheers :M

User avatar
CVI
Posts: 175
Joined: Mon Dec 03, 2007 12:01 pm
Member's Photo Album: http://cviauto.com
Vehicle: 1994 Delica Space Gear Royal Exceed
Location: Richmond, BC
Contact:

Re: Van trouble in Calgary

Post by CVI » Fri Jul 22, 2011 12:58 pm

Hi Patton...

Mardy is right! There is a small vac hose on the left hand side of your engine connected to the egr. All you need to do is to remove that hose from your egr and plug it. That's it.

There is a vac solenoid actuating the egr valve and that is apparently malfunctioning. That will cause all the loss of power and unburned fuel (black smoke) off your exhaust.

Good Luck,
CVI Automotive
JDM & Imported Vehicles Specialist
104-2353 Peardonville Road Abbotsford BC V2T 6J7
Phone: 604.710.7000 email: ati@atigroup.com.ph
Web: cviauto.com

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

RESOLVED

Post by pattonmaclean » Mon Jul 25, 2011 2:35 pm

Well, Jeanne-Claude Van Diesel is back on the road and running happily. First, I want to say thanks for all of the responses to the thread. Second, I need to say MARDY WARNED ME ABOUT THIS POTENTIAL PROBLEM WHEN I PICKED UP THE VAN LAST YEAR. I remembered the warning when I started to have the problem: fill up at about half a tank and save myself a potential headache. Today I had a phone conversation with Mardy as he walked me through a fix. I followed his directions , blocked the vac hose coming out of the EGR valve and pumped the fuel filter until it was hard, and presto! No smoke, no knocking, no hesitation. So thanks everyone, and thanks MARDY I'm on the road back to Saskatoon tomorrow morning. Great end to a fine folk festival k.d. lang was unreal on Saturday night.

User avatar
MardyDelica
Posts: 2190
Joined: Sun Jan 14, 2007 3:32 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: DL#30843 /92 Delica Super Exceed
Location: Richmond B.C.
Contact:

Re: Van trouble in Calgary

Post by MardyDelica » Mon Jul 25, 2011 5:53 pm

hi, patton,
glad that everything works for you now and help you what ever i could.
enjoy your new ride be a happy camper
have a safe trip back home;
Cheer;s
Mardy
ImageImageImage

Post Reply

Return to “L400 Technical”