Van trouble in Calgary

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 2:01 pm

Hey, I'm back in Canada for the summer, drove my L400 to Calgary from Saskatoon, and started having my first significant trouble with Van Diesel on the road.
I noticed more black smoke at accelerations than before, then some puffs of white smoke whenever I was starting from a stop. Significant loss of power, knocking and hesitation at low speeds which improves a bit as the van gains speed. It stalled twice starting at intersections this morning, loud knocking. I've been careful to use cetane enhancer since I bought the van last summer from Mardy. I checked oil before this trip aqnd it ewas fine, but haven't since I arrived. Three fillups ago I added one treatment of Bardahl injector cleaner, andf the van had been running like a champ. rpms yesterday didn't go over 2900. max speed never more than 130 but usually 115- 118. temperature gauge didn't go over mid point.

I just called Fuel Automotive in Strathmore and he's booked until August.

So I'm at my brother's, vanless in Calgary looking for recommendations on diesel shops here.

Also, any insisghts on the nature of the problem. My googling seems to indicate an injector problem, but I'm not much of a diesel engine mechanic as this is my first motor vehicle.

Any help much appreciated.

Patton

psilosin
Posts: 1045
Joined: Mon Mar 05, 2007 4:31 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: BC

Re: Van trouble in Calgary

Post by psilosin » Wed Jul 20, 2011 2:19 pm

How is your air filter and fuel filter looking?

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 3:18 pm

The air filter seems fine but I don't know how to locate the fuel filter.

I've called GCL Fuel Systems and Fuel Automotive in Strathmore, both of which are booked for the next two weeks.

bummer.

madmazda
Posts: 460
Joined: Mon Nov 10, 2008 2:03 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 l400
Location: calgary Alberta

Re: Van trouble in Calgary

Post by madmazda » Wed Jul 20, 2011 3:24 pm

call kirkham auto motive

User avatar
snelson
Posts: 406
Joined: Sat Jan 26, 2008 6:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 Delica Exceed
Location: Banff
Location: Banff, Alberta

Re: Van trouble in Calgary

Post by snelson » Wed Jul 20, 2011 3:40 pm

Look at your oil on the dip stick and in the filler cap.
Is it regular oily colour or milky/creamy colour?
The knocking and white smoke makes me think of head gasket. :-(

EDiT - Check coolant level too...

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 3:52 pm

Thanks for the advice. The oil looks clean and slightly pinkish. The coolant level seems fine. I'll try Kirkham, but understood they don't do actual diesel work.

madmazda
Posts: 460
Joined: Mon Nov 10, 2008 2:03 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1994 l400
Location: calgary Alberta

Re: Van trouble in Calgary

Post by madmazda » Wed Jul 20, 2011 4:00 pm

you could also be in need of a blanking plate on your egr......

User avatar
snelson
Posts: 406
Joined: Sat Jan 26, 2008 6:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 Delica Exceed
Location: Banff
Location: Banff, Alberta

Re: Van trouble in Calgary

Post by snelson » Wed Jul 20, 2011 4:01 pm

What colour is the coolant in your rad?
Green or red/pink?

User avatar
White Mule
Posts: 252
Joined: Wed Jul 16, 2008 4:48 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica P35
Contact:

Re: Van trouble in Calgary

Post by White Mule » Wed Jul 20, 2011 4:16 pm

Check fuel filter and all hose clamps. If there is any fuel moisture in that area, then air is also getting in. Causing knocking and smoke.

Ensure that the air filter is clean.

Oil should look like oil or on the black side. Pink doesnt sound right unless your antfreeze is red which would be not so good.

Dirty or clogged injector/s.

PM. If I can assist you. Stevo's auto recomended.
Thanks,

White Mule

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 4:21 pm

Inside the filler cap the oil seems black and maybe sooty. The dipstick is clean.
I called Rob at Kirkham, he suggested that it might be the fuel filter or pump, but wasn't sure if his crew had worked on either of those.

Not sure what to do...book a time at CGL or Fuel Automotive, fly home and come back here in a week to get the work done? Hmm, I feel my holiday slipping away.

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 4:35 pm

OMG now I see a second dipstick. The first one I was looking at was white and had a small clamp on it to hold it in place...that's where the pinkish fluid was. I'm now realizing that it is the coolant dipstick. The second dipstick is marked "engine" and has a small ball on the end of it.. I just checked it and the oil was very black on the end.

shit.

User avatar
White Mule
Posts: 252
Joined: Wed Jul 16, 2008 4:48 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica P35
Contact:

Re: Van trouble in Calgary

Post by White Mule » Wed Jul 20, 2011 4:43 pm

pattonmaclean wrote:I'm now realizing that it is the coolant dipstick.
That is your transmission fluid dipstick.
Thanks,

White Mule

pattonmaclean
Posts: 96
Joined: Tue Feb 02, 2010 12:09 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1995 L400 Spacegear Exceed
Location: Saskatoon
Location: Saskatoon, SK

Re: Van trouble in Calgary

Post by pattonmaclean » Wed Jul 20, 2011 4:54 pm

My first motor vehicle :oops:

Thanks for your help Mule. Ive had three service stations look and tell me that the oil level was fine, and now realize they (as well as I) didn't know mwhat they were looking at. 10W 40 good for this climate?

psilosin
Posts: 1045
Joined: Mon Mar 05, 2007 4:31 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: BC

Re: Van trouble in Calgary

Post by psilosin » Wed Jul 20, 2011 5:16 pm

If the air filter looks clean I would be checking the fuel filter (or getting a shop to if you don't want to) before getting too carried away and worried. Its cheap (~$25) and easy (screw off, screw on). If the van has been sitting around for a while while you were away then there is a strong likelyhood that stuff has been busy growing on your diesel in teh fuel tank and has now clogged up the fuel filter soon after driving it again. the fuel filter on the L400 is located on the right hand side of the engine bay beside the batteries.

Unlike gasoline vehicles where the fuel filters seem to last forever, diesel fuel filters are a much more common maintanance item since diesel is quite a nice growth media for bacteria. Even if it wasn't dirty diesel in your tank, all it takes is one bad fillup from a station as well. Having a spare fuel filter in your emergency kit is always a good idea since they can be difficult to locate and they never seem to get clogged in your driveway :-) .

User avatar
snelson
Posts: 406
Joined: Sat Jan 26, 2008 6:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 Delica Exceed
Location: Banff
Location: Banff, Alberta

Re: Van trouble in Calgary

Post by snelson » Wed Jul 20, 2011 5:51 pm

I was wondering if maybe that was your transmission dipstick you were referring to - I did the same thing for a few weeks when I got my L300.

That's good news, as already metioned by the other guys, bet it's a minor fuel/water/air issue....

THere's another shop called ProActive in Calgary, I had a good experience with them but some others have reported mixed experiences - they're in the NE, just off of 32 Ave.
:M

Post Reply

Return to “L400 Technical”