Engine Revs increase when in Neutral or Park

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
DelicaMark
Posts: 330
Joined: Mon Aug 20, 2007 9:37 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: Duncan, BC

Engine Revs increase when in Neutral or Park

Post by DelicaMark » Fri May 30, 2008 1:09 pm

Hey all,

We tossed this symptom around a few months back and many had experienced it, but we didn't really get anywhere. When I have been driving and get to my destination and put the van into park or neutral the revs will jump up to 1000-1200 rpm. I have checked the idle adjustment and the interesting thing about this is the screw on the idle adjustment is not touching the cam (or whatever it is called). It is like the throttle is being pressed even though it is not. Generally if I was to turn the engine on and off (without touching the throttle pedal) the revs don't jump up they stay at where the idle has been set.

This doesn't seem like a big deal but it didn't do this when I first got the van and now it does. Some had thought that it might have something to do with Winter diesel. I live on Vancouver Island and it sure isn't winter anymore...so I would assume that the winter diesel is gone now...maybe not though.

Any thoughts?

-Mark

bae146
Posts: 185
Joined: Thu Jan 31, 2008 9:12 am
Vehicle: 1991 Mitsubishi Pajero
Location: Calgary

Re: Engine Revs increase when in Neutral or Park

Post by bae146 » Fri May 30, 2008 2:26 pm

There is a high idle soloniod that will bring up the speed, this brings the cam off the stop. Having the AC on will engage this. On the pajero there is a temp sensor in the intercooler that will engage this as well.

User avatar
Fishtank
Posts: 320
Joined: Sat Mar 17, 2007 11:17 pm
Vehicle: 1994 Spacegear Exceed LWB Tall
Location: Okanagan
Location: Penticton

Re: Engine Revs increase when in Neutral or Park

Post by Fishtank » Fri May 30, 2008 2:30 pm

Mark,

Funny thing, my van seems to have picked up the same bad habit several weeks ago. It will rev up after a 5 minute drive to work, some days it does it, others it doesn't. Kinda weird I think, but I am going to try to lube my throttle cable somehow and see if that helps.

bae, this happens with my A/C off, does this mean the solenoid is shot, or is there an adjustment?

I'll be watching here to see if there is a real solution.

User avatar
DelicaMark
Posts: 330
Joined: Mon Aug 20, 2007 9:37 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: Duncan, BC

Re: Engine Revs increase when in Neutral or Park

Post by DelicaMark » Fri May 30, 2008 3:01 pm

I forgot to mention that the a/c is off as Fishtank mentioned. But if there is a solenoid that works with the a/c maybe it is not working properly even when the a/c is not in use.

-Mark

User avatar
jessef
Posts: 6457
Joined: Tue Feb 26, 2008 1:27 pm
Vehicle: JDM flavour of the month
Location: Vancouver
Location: Vancouver, BC

Re: Engine Revs increase when in Neutral or Park

Post by jessef » Fri May 30, 2008 3:41 pm

DelicaMark wrote:Hey all,

We tossed this symptom around a few months back and many had experienced it, but we didn't really get anywhere. When I have been driving and get to my destination and put the van into park or neutral the revs will jump up to 1000-1200 rpm. I have checked the idle adjustment and the interesting thing about this is the screw on the idle adjustment is not touching the cam (or whatever it is called). It is like the throttle is being pressed even though it is not. Generally if I was to turn the engine on and off (without touching the throttle pedal) the revs don't jump up they stay at where the idle has been set.

This doesn't seem like a big deal but it didn't do this when I first got the van and now it does. Some had thought that it might have something to do with Winter diesel. I live on Vancouver Island and it sure isn't winter anymore...so I would assume that the winter diesel is gone now...maybe not though.

Any thoughts?

-Mark
In Drive with the brake on, what is your idle speed ?

User avatar
marsgal42
Posts: 772
Joined: Fri Jul 20, 2007 3:05 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: The Mighty Gumdrop
Location: Burnaby, B.C.

Re: Engine Revs increase when in Neutral or Park

Post by marsgal42 » Fri May 30, 2008 7:55 pm

Gumdrop does the same thing when warm, idling at 750 RPM in Drive, 1000 in Neutral or Park. This is about how much the air conditioning idle kicker should boost the idle speed, but it makes no difference if the air is on or off.

Since I don't sit around idling much in Park or Neutral, I've never worried about it. 8-)

...laura

bae146
Posts: 185
Joined: Thu Jan 31, 2008 9:12 am
Vehicle: 1991 Mitsubishi Pajero
Location: Calgary

Re: Engine Revs increase when in Neutral or Park

Post by bae146 » Fri May 30, 2008 9:22 pm

Fishtank wrote:Mark,

Funny thing, my van seems to have picked up the same bad habit several weeks ago. It will rev up after a 5 minute drive to work, some days it does it, others it doesn't. Kinda weird I think, but I am going to try to lube my throttle cable somehow and see if that helps.

bae, this happens with my A/C off, does this mean the solenoid is shot, or is there an adjustment?

I'll be watching here to see if there is a real solution.
No it does not mean your solenoid is shot. (actually shows that it functions, the question really is what sends the signal for it to operate, is this one of those things that goes through the glow plug brain box? I remember someone saying there was a high idle function through the box as well.) On the Delica there could be another trigger for the high idle (my pajero has one in the intercooler and when I am using lots of turbo it will idle higher till it cools off, it also runs an electric fan under the intercooler for increased air flow.) There may be a water temp sensor that bumps the idle to allow for more radiator cooling with the increased fan speed. Any one else got any idea's? If I am incorrect in any of this please let me know.

User avatar
delicat
Posts: 2327
Joined: Thu Jul 26, 2007 6:26 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '92 Exeed '93 Safari '94 Pajero
Location: New Westminster, BC
Location: New Westminster, BC

Re: Engine Revs increase when in Neutral or Park

Post by delicat » Fri May 30, 2008 11:18 pm

Mine doesn't idle higher when on neutral or parked, just a nice and steady 750-800 RPM.

Aside from the solenoid described above I wonder if a vacuum leak could be the culprit. I could be talking from the left field here as I'm referring to past experience with non-diesel vehicle but some smart mechanic will make sure to correct me... :-)

David
'93 Nissan Patrol
'94 Mitsubishi Pajero
Image

"If it ain't broken, modify it!"

EricN
Posts: 394
Joined: Tue Aug 07, 2007 7:49 am
Vehicle: 90 exceed
Location: Coquitlam

Re: Engine Revs increase when in Neutral or Park

Post by EricN » Sat May 31, 2008 8:33 am

delicat wrote:I wonder if a vacuum leak could be the culprit. I could be talking from the left field here
David

Yes you are
delicat wrote:some smart mechanic will make sure to correct me... :-)

David
Done. :)

User avatar
marsgal42
Posts: 772
Joined: Fri Jul 20, 2007 3:05 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: The Mighty Gumdrop
Location: Burnaby, B.C.

Re: Engine Revs increase when in Neutral or Park

Post by marsgal42 » Sun Jun 01, 2008 9:50 am

To amplify a little bit on this: the intake manifold in diesel engines is always wide open. They pull no appreciable manifold vacuum, so an air leak won't do anything. This is why our Delicas have a vacuum pump on the back of the alternator to make the power brakes work.

(Yes, that was me in Victoria yesterday)

...laura

g_man1972
Posts: 111
Joined: Mon Sep 17, 2007 9:52 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 super exceed
Location: Vancouver

Re: Engine Revs increase when in Neutral or Park

Post by g_man1972 » Sun Jun 01, 2008 3:39 pm

Mine use to do this too. While I don't know what causes it, I can shed a little light on it by saying that I recently had my injector pump rebuilt due to my govenor sleeve sticking and it doesn't do it anymore, sits nice and happy around 700 hot, cold, drive, neutral, park. Don't know if this is any help, but maybe it's something connected to it, or related in some way... yea, probably of no help what so ever. I know, anyhoo I tried :-)

User avatar
TardisDeli
Posts: 1422
Joined: Tue Sep 18, 2007 10:57 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 L300. 1997 L300.
Location: Burnaby
Location: Burnaby, Gaglardi freeway exit
Contact:

Re: Engine Revs increase when in Neutral or Park

Post by TardisDeli » Sun Jun 01, 2008 4:25 pm

Hi all, wasn't there a similar posting in the last 2 0r 3 weeks, with the result being a stuck "Governor Sleeve", and how they fixed it. Does anyone recall more details? Maybe this is similar?? Christine.

g_man1972
Posts: 111
Joined: Mon Sep 17, 2007 9:52 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 super exceed
Location: Vancouver

Re: Engine Revs increase when in Neutral or Park

Post by g_man1972 » Mon Jun 02, 2008 10:45 am

That was me, the post is in Troubleshooting, but I had a lots more symptoms then just the increased idle. But like I said maybe they are connected in some way, like something had to be taken apart and then reassembled to get access and during this reassembly what ever was causing the increased idle speed was reassembled correctly. Anyway like I said, used to do it... doesn't do it anymore, gotta be something to do with it. One more thing I noticed is that before when I was running the A/C and the compressor would kick in the RPM would jump way up to like 13-1400 and if I was in drive I had to be pretty sharp to keep the foot on the brake otherwise she would surge forward. Now it doesn't do that either, idle only goes up maybe like 50-100 rmp when it is cycling on and off.

User avatar
CVI
Posts: 175
Joined: Mon Dec 03, 2007 12:01 pm
Member's Photo Album: http://cviauto.com
Vehicle: 1994 Delica Space Gear Royal Exceed
Location: Richmond, BC
Contact:

Re: Engine Revs increase when in Neutral or Park

Post by CVI » Mon Jun 02, 2008 1:05 pm

You may want to check the throttle cable adjustment first. It should be on the little bit of a loose side on idle. Nest, I would lubrictate the throttle itself connecte to the injection pump and make sure it is not sticking whenever you manually move the throttle. Then I would check the "idle up" adjustment too. This is actuated everytime the A/C compressor turns on. What it's suppose to do is just maintain the idle at 750rpm and nothing more. If the A/C turns on and the idle goes up by 100 or more rpms, it should be adjusted to idle just enough at 750. There is an adjusting nut on the lever that pulls the throttle forward as the solenoid activates. You can observe how it works when you play around with the A/C switch and see what happens.

I hope it helps...

mitsubc
CVI Automotive
CVI Automotive
JDM & Imported Vehicles Specialist
104-2353 Peardonville Road Abbotsford BC V2T 6J7
Phone: 604.710.7000 email: ati@atigroup.com.ph
Web: cviauto.com

User avatar
DelicaMark
Posts: 330
Joined: Mon Aug 20, 2007 9:37 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: Duncan, BC

Re: Engine Revs increase when in Neutral or Park

Post by DelicaMark » Tue Jun 03, 2008 12:20 pm

Thanks for the input on this everyone. There seems like a few real possibilites here. I have been busy with our new baby that came a couple of weeks early....I have a feeling that my van's idle issue will not be fixed in the near future! :-)

-Mark

Post Reply

Return to “L300 Technical”