A/T temp, fuel filter, battery lights all on?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
pluckmyeyeout
Posts: 125
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

A/T temp, fuel filter, battery lights all on?

Postby pluckmyeyeout » Sun Apr 08, 2018 2:07 pm

A/T temp, fuel filter, battery lights all coming on at the same time and then sometimes fading in/out with RPMs. Eventually when the vehicle is warmed up, the lights go off and then when the RPMs are revved the lights come on with the increasing RPMS. Any ideas?

User avatar
Growlerbearnz
Posts: 1805
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

A/T temp, fuel filter, battery lights all on?

Postby Growlerbearnz » Sun Apr 08, 2018 6:53 pm

Faulty alternator. The battery/alternator light is also wired in parallel with the A/T and fuel filter lights, so when the battery light comes on they all do. (Though the A/T and filter lights can come on on their own, since they're connected to the battery light through diodes).

I think it's wired this way so you know that the AT and filter lights are working before you start the engine. Other vehicles have a timer that does the same thing, but it looks like Mitsubishi cheaped out here.
Nothing says "poor workmanship" more than wrinkles in the duct tape.


Return to “L300 Technical”

Who is online

Users browsing this forum: No registered users and 5 guests