Video L300 cold start. Fouled injectors?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
north54
Posts: 177
Joined: Tue Oct 01, 2013 10:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 P35W
Location: Vancouver

Video L300 cold start. Fouled injectors?

Postby north54 » Mon Feb 19, 2018 8:34 pm

Hey guys it was a tad cold this morning around -5C (23F) so I filmed this little clip cold starting the van. Have not started it in a couple days. I haven't had my injectors properly cleaned either. Since my idle is rough even after the van is warmed I feel like I'm due for an injector rebuild. I'm wondering if the 3 or 4 puffs of white smoke are attributed to the injectors or the glow plugs?



Appreciate the info, stay warm out there Canadians.
TRUSTY RUSTY

msimps
Posts: 32
Joined: Wed Apr 06, 2016 7:59 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica L300 Super Exceed
Location: Delta

Video L300 cold start. Fouled injectors?

Postby msimps » Mon Feb 19, 2018 9:09 pm

Just did my glow plugs and mine smokes worse than yours on cold starts...


Sent from my iPhone using Tapatalk
Last edited by msimps on Mon Feb 19, 2018 9:09 pm, edited 1 time in total.

User avatar
Growlerbearnz
Posts: 1944
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

Video L300 cold start. Fouled injectors?

Postby Growlerbearnz » Tue Feb 20, 2018 11:08 pm

Now you're just trolling. That's about the nicest engine startup I've seen below freeing. Yes, there's a couple of puffs of blue (along with the usual black), but nothing unexpected. :-) My old Isuzu would spew white smoke for about a minute at those temperatures, and it was 3 years old with 20,000km!

My only advice would be to get the engine revs up to 1000-1200rpm as soon as it starts, and use the idle speed knob to keep them there until the temperature gauge starts to move. It'll idle much smoother since the alternator is trying as hard as it can to recharge the battery after running the glowplugs.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

User avatar
north54
Posts: 177
Joined: Tue Oct 01, 2013 10:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 P35W
Location: Vancouver

Video L300 cold start. Fouled injectors?

Postby north54 » Wed Feb 21, 2018 3:40 pm

Weird, okay thanks everyone. Guess I'm doing something right in the maintenance. It still idle's rough so I'm sure its due for an injector clean. I'll troll somewhere else now.... :-)
TRUSTY RUSTY

User avatar
Growlerbearnz
Posts: 1944
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

Video L300 cold start. Fouled injectors?

Postby Growlerbearnz » Thu Feb 22, 2018 1:48 am

You might be due for an injector clean, but don't expect it to substantially improve your starting.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

john clem
Posts: 55
Joined: Wed Oct 10, 2007 11:38 pm
Vehicle: 1992 delica

Video L300 cold start. Fouled injectors?

Postby john clem » Mon Feb 26, 2018 4:28 am

older technology diesel its normal probably because the combustion chamber needs to warm up to get a good fuel burn


Return to “L300 Technical”

Who is online

Users browsing this forum: No registered users and 7 guests