Phillips & Temro Circulating Coolant Heater

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
ACKO15
Posts: 27
Joined: Fri Jul 28, 2017 3:39 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica L300
Location: Cape Breton

Phillips & Temro Circulating Coolant Heater

Postby ACKO15 » Fri Feb 02, 2018 10:13 am

Hi folks,

So, I have recently decided to help the old girl, '91 L300 4D56, with a new coolant heater. I wasn't a huge fan of the block heater install, due to the inaccessibility and potential for a hard-to-reach leak.

The heater is a Phillips & Temro, Series 41 1000W circulating type tank heater, installed in the rear heater hoses. https://phillipsandtemro.com/solutions/ ... n-heaters/

I have installed it in-line with the coolant hose running into the transverse steel pipe leading to the top, rear of the block, passenger side (look for transmission dipstick mount). The heater provides lots of natural circulation in this location, and leaves the block at 40-50C with outdoor temperatures of -10C.

If anybody is looking for an easy installation, effective heater to warm the whole system, this heater is great. It took about 30 minutes to install, and came with a mounting bracket which I cut and fitted to an existing bolt. No glow plugs needed, and hot air available in less than 5 minutes is a nice change!

Just an FYI, hope it helps.

Ralph in Winnipeg
Posts: 102
Joined: Wed Sep 02, 2015 7:42 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94 Strada
Location: Winnipeg

Phillips & Temro Circulating Coolant Heater

Postby Ralph in Winnipeg » Tue Feb 06, 2018 6:12 am

That looks pretty slick! You have to love quick, easy and effective. What's the cost?

Ralph in Winnipeg

User avatar
ACKO15
Posts: 27
Joined: Fri Jul 28, 2017 3:39 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica L300
Location: Cape Breton

Phillips & Temro Circulating Coolant Heater

Postby ACKO15 » Wed Feb 07, 2018 2:44 pm

Cost about 140$ at NAPA. There are other models from 90-160$ available.

Cambullos
Posts: 11
Joined: Mon Oct 12, 2015 2:46 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi Delica L300
Location: Vancouver

Phillips & Temro Circulating Coolant Heater

Postby Cambullos » Fri Feb 09, 2018 9:51 am

What a coincidence! My mechanic in Windsor was trying to convince me to go with this type of system over a block heater.

Is it a fairly reasonable install as in should I attempt on my own? Special tools required to mount the unit? Where does the plug-in hang out of the body?


Cheers,
Matt

Sent from my SM-G920W8 using Tapatalk

User avatar
bonge31
Posts: 26
Joined: Sat Dec 23, 2017 4:24 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica P35W
Location: France

Phillips & Temro Circulating Coolant Heater

Postby bonge31 » Sat Feb 10, 2018 3:27 pm

ACKO15 wrote:Hi folks,

So, I have recently decided to help the old girl, '91 L300 4D56, with a new coolant heater. I wasn't a huge fan of the block heater install, due to the inaccessibility and potential for a hard-to-reach leak.

The heater is a Phillips & Temro, Series 41 1000W circulating type tank heater, installed in the rear heater hoses. https://phillipsandtemro.com/solutions/ ... n-heaters/

I have installed it in-line with the coolant hose running into the transverse steel pipe leading to the top, rear of the block, passenger side (look for transmission dipstick mount). The heater provides lots of natural circulation in this location, and leaves the block at 40-50C with outdoor temperatures of -10C.

If anybody is looking for an easy installation, effective heater to warm the whole system, this heater is great. It took about 30 minutes to install, and came with a mounting bracket which I cut and fitted to an existing bolt. No glow plugs needed, and hot air available in less than 5 minutes is a nice change!

Just an FYI, hope it helps.

Could you post some pictures about your installation? I'm very interested about it.
I saw it works with 240v or 120v? Did you put a converter?
Is it directly connected to the battery via a switch ?

Thanks a lot!

Sent from my ONEPLUS A3003 using Tapatalk


Return to “L300 Technical”

Who is online

Users browsing this forum: No registered users and 6 guests