engine cut out at 2xxx RPMs?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Wed Dec 20, 2017 9:10 am

Welp, finally got the Delica going after 15 months of no-start. See here for history: viewtopic.php?f=6&t=17840

Now it's starting, and driving, which is really just the best.

But!

It's starting rough. Plenty of white smoke. After 30~ seconds it usually gets going OK. Only on cold start...

And then when it's running, if I step on the gas and get the RPMs up to 2xxx (sometimes it's 2200, sometimes it's 2500, sometimes it's 2800) it just cuts out. I thinking the old fuel and 15 months of no-start probably had something to do with it. But also burned through the old fuel and it's got a fresh tank in there now.

What think?

User avatar
feetforbrains
Posts: 73
Joined: Sun Sep 17, 2017 10:59 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica L300 Chamonix
Location: US

engine cut out at 2xxx RPMs?

Postby feetforbrains » Wed Dec 20, 2017 9:52 am

Sounds familiar, look for oil in and around your turbo.

Sent from my Pixel 2 using Tapatalk

User avatar
weelsey
Posts: 65
Joined: Mon Nov 13, 2017 5:36 pm
Member's Photo Album: http://www.delica.ca/Photos/profile.php?uid=15295
Vehicle: '90 2.5l high roof exceed
Location: edmonton

engine cut out at 2xxx RPMs?

Postby weelsey » Wed Dec 20, 2017 10:50 am

A lot has happened with it. Does it have any power up to those revs? I guess so if you're going through some fuel. idle normally once warm? Perhaps you would want to see if the your cut-out is related to fuel supply. One can run a 12v jumper to the fuel-cut solenoid. One can try to test drive with an alternate fuel cell inside the vehicle. One can install a vacuum gauge between the pump and the fuel filter.

I have heard that considerable dry cranking can cause wear to IP internals such as vanes. I don't have any first hand experience with this kind of wear on the internal pump vanes. But I have successfully used a low-pressure fuel pump to help supply fuel to the IP when it would have otherwise stalled.

Perhaps I haven't got it but it's the line of inquiry that comes to mind.

User avatar
Growlerbearnz
Posts: 1938
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

engine cut out at 2xxx RPMs?

Postby Growlerbearnz » Wed Dec 20, 2017 1:23 pm

I'm glad you're persevering.

So when you hit 2XXXrpm does it cough and sputter and try to stall out, or does it just sit there at 2XXXrpm like everything's fine and that's as fast as it will go?

Will it rev above 2XXXrpm when it's in neutral?

Stalling is pretty extreme, I'd be looking at the power supply to the cutoff solenoid. There may be an internal break in a wire that only shows up when it vibrates at a certain frequency- I would try hooking up a new wire from the battery + directly to the solenoid, and see if it still cuts out.

If it's running fine but just wont go above 2XXX rpm it sounds like the governor in the IP is sticky, or the full load adjusting screw has moved (it's above the fuel cut solenoid).

...but mostly I suspect your fuel pump has issues, and it might be time for a rebuild (or at least a thorough strip down and inspection). Something's not right.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

planbrad
Posts: 6
Joined: Sun Jul 05, 2015 9:13 pm
Vehicle: 94 L400 Diesel C-Lite
Location: Kelowna

engine cut out at 2xxx RPMs?

Postby planbrad » Mon Jan 01, 2018 9:15 pm

Currently havingg the same issue. What was your issue in the end? Any suggestions on where to start?!

Brad

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Tue Jan 09, 2018 11:09 am

Growlerbearnz wrote:I'm glad you're persevering.

So when you hit 2XXXrpm does it cough and sputter and try to stall out, or does it just sit there at 2XXXrpm like everything's fine and that's as fast as it will go?

Will it rev above 2XXXrpm when it's in neutral?

Stalling is pretty extreme, I'd be looking at the power supply to the cutoff solenoid. There may be an internal break in a wire that only shows up when it vibrates at a certain frequency- I would try hooking up a new wire from the battery + directly to the solenoid, and see if it still cuts out.

If it's running fine but just wont go above 2XXX rpm it sounds like the governor in the IP is sticky, or the full load adjusting screw has moved (it's above the fuel cut solenoid).

...but mostly I suspect your fuel pump has issues, and it might be time for a rebuild (or at least a thorough strip down and inspection). Something's not right.


No stalling. It coughs and cuts out. If I let off the throttle it shifts up and RPMs go down, and then it's fine. Doesn't cut in neutral. Also seems to depend on whether or not it's cold. It happens more when it warms up. Unfortunately, this isn't the most pressing issue at the moment. It's drivable as is and it's been cold AF, so doing anything mechanical without a garage has been challenging.

I think the rebuild is the plan regardless, but I'll see if I can check the full load adjusting screw can be adjusted. I wouldn't be surprised if that was the culprit to be honest.

adaxi
Posts: 8
Joined: Sun Nov 13, 2016 5:15 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L400
Location: london

engine cut out at 2xxx RPMs?

Postby adaxi » Sat Jan 20, 2018 3:30 pm

Im having a similar problem at the same rpms...but there some sputtering and then around 60km the delica starts making a vibrating sound


Sent from my iPhone using Tapatalk

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Mon Oct 08, 2018 7:00 am

Where's that full load adjusting screw? Anyone got a picture/diagram?

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Mon Oct 08, 2018 7:56 am

So this is above the fuel cutoff solenoid... Is it a cover to the screw or is it the screw itself?
Attachments
2018-10-08 10.46.16.jpg
2018-10-08 10.46.16.jpg (418.37 KiB) Viewed 458 times

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Mon Oct 08, 2018 8:56 am

Another observation. This is happening more when the engine is hot... Any additional thoughts?

Sent from my Pixel 2 using Tapatalk

User avatar
Growlerbearnz
Posts: 1938
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

engine cut out at 2xxx RPMs?

Postby Growlerbearnz » Tue Oct 09, 2018 1:23 am

That's the screw, but it still has its anti-tamper cover on, which suggests it's not been messed with. (The screw without cover is shown in step 10 of this post:http://www.delica.ca/forum/viewtopic.php?f=100&t=19015&p=139658)

The cutting out is the odd bit. A faulty governor and throttle linkage might prevent you revving past 2xxx rpm, but it can't cut the fuel. I wonder if there's some kind of air leak that only becomes a problem at higher revs, maybe churning air into the diesel that fills the IP, the air then would disable the injectors? It's not something I've come across before though.

Weelsley had an interesting thought re: injection pump vanes. There's a low-pressure pump stage inside the IP to suck fuel from the tank into the IP, if one of the vanes was stuck it might run out of suck at high revs.

You went through the fuel lines and filter (the usual source of air leaks) when it refused to start before.

I think it's time to strip down the IP and injectors for a full overhaul, and have them all calibrated back to factory settings by a diesel injection shop.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

sk66
Posts: 159
Joined: Thu Oct 06, 2016 3:24 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '91 Delica L300
Location: Pennsylvania, USA

engine cut out at 2xxx RPMs?

Postby sk66 » Wed Oct 10, 2018 7:51 am

I didn't go back through the previous history, but what about a fuel restriction... the little hidden filter screen at the injection pump?

I'm thinking that it's likely a flow restriction because it happens at somewhat variable RPMs and not at all in neutral... the same amount of fuel/flow rate results in different RPM's with different loads applied (including the extra drag of a cold engine). And if the demand exceeds the supply it will cough/stutter at that throttle setting (momentary starvation).
Steven
1991 L300
Harrisburg, PA

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Tue Oct 16, 2018 7:11 am

Talked to a Chrysler tech (who also has a 4D56 equipped Pajero) this weekend who suggested this could be a clogged EGR tube. He said this is something he's seen on the 12v Cummins. Thinking about cleaning it out and also blanking. Any thoughts?
Last edited by pluckmyeyeout on Tue Oct 16, 2018 7:12 am, edited 1 time in total.

User avatar
pluckmyeyeout
Posts: 134
Joined: Sat May 14, 2016 6:14 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1991 Delica Chamonix (JDM)
Location: Boston, MA, USA

engine cut out at 2xxx RPMs?

Postby pluckmyeyeout » Tue Oct 16, 2018 7:12 am

sk66 wrote:I didn't go back through the previous history, but what about a fuel restriction... the little hidden filter screen at the injection pump?



Where is that screen? How would one check it/clean it/clear it?

sk66
Posts: 159
Joined: Thu Oct 06, 2016 3:24 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '91 Delica L300
Location: Pennsylvania, USA

engine cut out at 2xxx RPMs?

Postby sk66 » Tue Oct 16, 2018 8:48 am

pluckmyeyeout wrote:Talked to a Chrysler tech (who also has a 4D56 equipped Pajero) this weekend who suggested this could be a clogged EGR tube. He said this is something he's seen on the 12v Cummins. Thinking about cleaning it out and also blanking. Any thoughts?

I doubt it... the performance with a plugged/obstructed EGR is the same as with it removed/blanked. I blanked mine...largely for a place to put an EGT probe, but also because I believe mine was sticking open even after I cleaned it (symptoms returned, poorer/smokier starts/idle and poorer acceleration w/ heavy throttle).
Steven
1991 L300
Harrisburg, PA


Return to “L300 Technical”

Who is online

Users browsing this forum: No registered users and 11 guests