A new record?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
joebillhill
Posts: 124
Joined: Wed Apr 02, 2014 10:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 Mitsubishi Delica l300
Location: United States

A new record?

Postby joebillhill » Wed Nov 08, 2017 1:51 pm

So as I pulled into a friend's house last night I caught the whiff of burning antifreeze...
Checked under the seat and nothing from the top view of the engine was leaking. I couldn't get a good view of under the driver's seat though and I haven't gotten a really good look underneath to see a leak.
This morning I took a peak and my coolant reservoir was low. Filled it up some, fired her up, and driving around im putting off some whitish exhaust and get that sweet smell of coolant when the winds are right.
It would seem to me I have a failed head gasket unless somebody can brighten my day and say otherwise. This gasket only made it 40k km too. Impressively bad.
I'm curious if it's a record? Maybe a consolation prize is in order.
Anyways, does anyone have any thoughts on this? It seemed like the van was running just fine. I was finagling with the boost compensator but was keeping an eye on egts as always.
Coolant was clean, cooling system was new, along with cylinder head and block, temp guage hardly moved (occasionally up to 1/2, maybe once up to 3/4) I've got a pyro pre turbo that i tried to keep at under 1200f.
If I decide to revive her I'd like to not run into the same problem.

User avatar
north54
Posts: 121
Joined: Tue Oct 01, 2013 10:29 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 P35W
Location: Vancouver

A new record?

Postby north54 » Wed Nov 08, 2017 2:37 pm

Tough break Joe, was it a genuine OEM replacement gasket?
TRUSTY RUSTY

User avatar
joebillhill
Posts: 124
Joined: Wed Apr 02, 2014 10:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 Mitsubishi Delica l300
Location: United States

A new record?

Postby joebillhill » Wed Nov 08, 2017 4:50 pm

Yeah to my knowledge it was. Coobs replaced it when they installed the block.

User avatar
Growlerbearnz
Posts: 1454
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

A new record?

Postby Growlerbearnz » Wed Nov 08, 2017 9:26 pm

Getting 40k out of it must be frustrating. If the head was warped or cracked when reinstalled I doubt it would have lasted that long. I suspect the head was stressed when it overheated previously (but not enough to show up when measured or crack tested), and has probably now cracked.

Definitely have the head crack tested, and measure both the head and block for straightness. Pay attention to the torque on the head bolts when removing them, if any are significantly looser than the rest then check the head and block for signs of damage near the loose bolts, and check the bolts for pitting or stretch.

Use new bolts when installing the next head.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

Morgonzo
Posts: 205
Joined: Sun Oct 02, 2016 8:11 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L300
Location: GA USA

A new record?

Postby Morgonzo » Thu Nov 09, 2017 7:31 pm

Sad news Joe. Any hope of a warranted repair for premature failure?
The "Zanimo Wagon" 1988 Mitsu Delica L300 StarWagon P25W 5spd :M
"Zowie Zow!" :-D

User avatar
joebillhill
Posts: 124
Joined: Wed Apr 02, 2014 10:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1989 Mitsubishi Delica l300
Location: United States

A new record?

Postby joebillhill » Mon Nov 13, 2017 2:20 pm

Sad news Joe. Any hope of a warranted repair for premature failure?

I don't think so. It was a 20k km warranty and I have gone across the country and back.
Thanks Growler I'll take that stuff into consideration. Also should I/is there a way to test the water pump for failure or would I have been able to tell otherwise if it or my cooling system was at fault?


Return to “L300 Technical”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests