Crank Pulley (balancer) marks don't line up. Spun?

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
User avatar
ynwa
Posts: 104
Joined: Sat Mar 26, 2016 10:59 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L300 Starwagon TD
Location: Victoria

Crank Pulley (balancer) marks don't line up. Spun?

Postby ynwa » Sun Jan 01, 2017 11:38 am

I'm thinking the pulley has spun on the rubber but wondered what you all have to say. I'm attempting to set the pump timing and have the cam/pump marks lined up fine. However, the crank pulley mark is about 30deg advanced (before the case marks). This might sound short term but I was thinking to add a new mark on the pulley where TDC should be, then set the timing.

Think I'm looking at a new pulley? Them things are 'spensive...

This is how far out the cam mark is when the crank pulley thinks it's at TDC. Note that both the IP and Cam marks sync up just fine.
timing-marks.jpg
timing-marks.jpg (64.13 KiB) Viewed 261 times
1991 L300 TD Low Roof

User avatar
ynwa
Posts: 104
Joined: Sat Mar 26, 2016 10:59 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L300 Starwagon TD
Location: Victoria

Crank Pulley (balancer) marks don't line up. Spun?

Postby ynwa » Sun Jan 01, 2017 2:04 pm

Nevermind, my Delica dream appears to be over. Keyway shattered...
Attachments
harmonic-balancer.jpg
harmonic-balancer.jpg (70.26 KiB) Viewed 255 times
crank-keyway.jpg
crank-keyway.jpg (50.13 KiB) Viewed 255 times
1991 L300 TD Low Roof

204explorer
Posts: 106
Joined: Sun Oct 02, 2016 10:19 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: l400
Location: CA

Crank Pulley (balancer) marks don't line up. Spun?

Postby 204explorer » Sun Jan 01, 2017 7:06 pm

Sorry to hear about your bad luck.

Sent from my SM-G920W8 using Tapatalk

User avatar
Growlerbearnz
Posts: 1272
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

Crank Pulley (balancer) marks don't line up. Spun?

Postby Growlerbearnz » Tue Jan 03, 2017 8:54 pm

Damn. That's the end of that crankshaft. :-(
Something something Dark Side, something something Complete.

Morgonzo
Posts: 200
Joined: Sun Oct 02, 2016 8:11 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L300
Location: GA USA

Crank Pulley (balancer) marks don't line up. Spun?

Postby Morgonzo » Wed Jan 04, 2017 11:27 am

That really sucks... :-( sorry this happened to your Deli. Are you going to try to fix it or are you totally fed up with it now?
The "Zanimo Wagon" 1988 Mitsu Delica L300 StarWagon P25W 5spd :M
"Zowie Zow!" :-D

User avatar
ynwa
Posts: 104
Joined: Sat Mar 26, 2016 10:59 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: L300 Starwagon TD
Location: Victoria

Crank Pulley (balancer) marks don't line up. Spun?

Postby ynwa » Mon Apr 17, 2017 9:36 pm

Whoops, sorry for not replying. Nope, I kept her going.
Pulled everything off, new sprockets, keys, harmonic balancer from Ebay. Set the new keys in and lathered everything in LockTite 660 (wow, pricey goop). Oh, and a new crankbolt of course. Torqued it all down and have been driving for a couple months now. :)

I'm not fooling anyone however. I plan on rebuilding the motor this summer while I have a 650GS to boot around in. Definitely not done yet!

Cheers! Seen lots of Deli's around Victoria. If you're out there holler. 'Specially the Tofino Bus getting work done at Prospect Auto. :)
1991 L300 TD Low Roof


Return to “L300 Technical”

Who is online

Users browsing this forum: No registered users and 1 guest