no turn signals or 4 way flashers

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
Post Reply
captainfalcon
Posts: 8
Joined: Tue Jan 11, 2011 10:55 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Yahama BWS
Location: Victoria

no turn signals or 4 way flashers

Post by captainfalcon » Sat Apr 28, 2012 8:59 am

I had the dash off the other day and was fiddling around running wires for my stereo. After potting everything back together and attempting to drive away bumping the new tunes I realized that my turn signals were not working. No clicking, nothing. Tried the hazard switch and nothing there as well. I tested both fuses and they are both good.

So I'm wondering if maybe I disconnected something while I was working under the dash, specifically under the steering column/radio area? I popped the dash off again and attempted to trace the flasher wire but there is nothing I can see.

Possibly 2 is that I have shorted out my flasher relay while wiring up this stereo.Is there any surefast way to diagnose this?

Cheers!

User avatar
CVI
Posts: 175
Joined: Mon Dec 03, 2007 12:01 pm
Member's Photo Album: http://cviauto.com
Vehicle: 1994 Delica Space Gear Royal Exceed
Location: Richmond, BC
Contact:

Re: no turn signals or 4 way flashers

Post by CVI » Sat Apr 28, 2012 9:04 am

Check your flasher unit connectors. You might have forgotten to reconnect them when you reinstalled the dash... :-D
CVI Automotive
JDM & Imported Vehicles Specialist
104-2353 Peardonville Road Abbotsford BC V2T 6J7
Phone: 604.710.7000 email: ati@atigroup.com.ph
Web: cviauto.com

captainfalcon
Posts: 8
Joined: Tue Jan 11, 2011 10:55 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Yahama BWS
Location: Victoria

Re: no turn signals or 4 way flashers

Post by captainfalcon » Sun Apr 29, 2012 2:23 pm

fantastic ill give that a go. Just to clarify, the connectors your talking about are the ones that come out of the steering column under the dash?

Post Reply

Return to “L300 Technical”