Delayed Starting & Low Idle

Does your Mitsubishi L300 make a strange noise? Need wheel alignment specs?
Post Reply
philmeup1
Posts: 464
Joined: Wed Aug 22, 2012 6:20 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1992 Delica
Location: Ontario

Delayed Starting & Low Idle

Post by philmeup1 » Sat Aug 10, 2019 9:48 am

Hello folks,

After enjoying almost 7 years of worry free driving with my 1993 Mitsubishi Delica L300, I've got a little glitch happening intermittently when starting it up. Usually I just turn the key, wait for the click and boom, it fires right up. lately it's been turning over for about 3 - 5 seconds before catching. And when it does fire up, the idle will be so low that I have to push on the accelerator to keep it running. After this, it seems to run just fine.

I'm no expert here, but I'm thinking it might be time to change the fuel filter? It was replaced by myself 7 years ago when I bought my van, but I think I read somewhere that these things need to be changed often because of possible water in the in the fuel.... or anything else for that matter.

Anyway, I have a spare one that I purchased from Rising Sun, and it looks like a fairly easy Job. But I'd love to hear other thoughts and opinions on whether I'm on the right track or not.

Thanks all:)

Phil

User avatar
Growlerbearnz
Posts: 2009
Joined: Sat Jun 26, 2010 1:58 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Delica P25W
Location: New Zealand

Delayed Starting & Low Idle

Post by Growlerbearnz » Sat Aug 10, 2019 2:56 pm

Changing the fuel filter is a good idea.

Delayed starting is usually from air leaking into the IP and lines, and the usual culprit is split fuel hoses. Check the ends of all the fuel hoses for splits:
perished.jpg
perished.jpg (25.93 KiB) Viewed 87 times
You can usually just cut an inch off the hose to get past the split part.

Also look for any fuel leaks. If fuel can leak out, air can get in. If the IP is dripping you might have a dodgy seal.

Take the top timing belt cover off and check around the IP sprocket. If the IP front shaft seal starts to leak it'll get diesel on the timing belt, which will destroy the belt. That seal doesn't leak very often, but the consequences of a failed belt make it worth checking.
Nothing says "poor workmanship" more than wrinkles in the duct tape.

philmeup1
Posts: 464
Joined: Wed Aug 22, 2012 6:20 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1992 Delica
Location: Ontario

Delayed Starting & Low Idle

Post by philmeup1 » Sun Aug 11, 2019 5:24 am

Well Growler, once again you're exactly spot on!! I've been visiting at a friend's over the weekend. I parked my van in his super clean garage with a concrete floor. I notice diesel fuel on the floor about where the sliding door is, on that side when I moved the van.

I'll check on those fuel lines as you suggested and either repair or replace the damaged ones.

Thanks as always for your input:)

Phil

Post Reply

Return to “L300 Technical”