ECU problems??? cold start problems TURBO ISSUE?

A close "cousin" of the Mitsubishi Delica
Jiustin
Posts: 6
Joined: Thu Sep 06, 2012 11:30 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi pajero v44 4d56
Location: Calgary

ECU problems??? cold start problems TURBO ISSUE?

Postby Jiustin » Fri Oct 04, 2013 5:33 pm

so heres the scoop ive had my 1991 V44 pajero ive been battling the cold start issue for about 3 years now heres what i have done..

-started with the glowplugs ordered the proper glowplugs mitsubishi green top quick starts
- replaced the outdoor temperature sensor
- replaced the glowplug relays with brand new relays.
- cleaned the busbar.
-cleaned intercooler and lines
-cleaned egr
- replacced fuel filter and added injector cleaner.

so heres where i am at now the paj runs great when warm it starts sometimes when it gets down to about -15
issues im looking towards now are 1 need to check the engine control unit ... ( ive opened it up and looked for burnt spots and such but it seems ok)
im looking for someone in the calgary area that either knows how to check ECU"S or has a paj with the same ecu as mine that is running in tip top shape i have my ecu and paneling out and ready to be checked.

if anyones got any experience with this stuff id like to chat or even if you know anywhere in town that can repair or fix ECU"s that would be awesome..
2nd and 3rd possible cold start issues are 2- the turbo is pretty much effed its still running but its squeals like a dead pig sometimes and i know i will need to replace it soon ( planning on ordering one from rocky mountain imports)
3rd problem is ive noticed that the fuel pump is a bit wet sometimes i figure there is a minor leak somewhere >>> How much will it cost to get it rebuilt and retuned?

User avatar
Big-Bird
Posts: 1217
Joined: Thu Dec 08, 2011 5:57 pm
Member's Photo Album: http://www.delica.ca/Photos/index.php?cat=20974
Vehicle: 96 PE8W Spacegear
Location: Calgary

Re: ECU problems??? cold start problems TURBO ISSUE?

Postby Big-Bird » Sat Oct 05, 2013 9:41 am

The turbo squeals. If the rotation of the turbo has too much resistance this can cause slight back pressure into the cylinders. The engine will still start but runs way below peak levels when driving.

My money is on your fuel pump which is a common problem since our Canadian diesel has less sulphur, which is a lubricant, which in turn causes seals to wear out faster unless you use a fuel-lube additive. There are not too many experienced Mitsu Diesel techs in Calgary but if you call Finning or the local Fuso dealer here in Calgary they do have techs who can and do work on the 4m40 and 4d56 engines in our smaller Mitsu's. FYI Some of Caterpillars small tracked equipment uses the Mitsu 4M40(2.8L).

I had Butch at CVI rebuild mine because he said it started poorly in the cold,he checked mine over is March 2012. He showed me the seals and they were wore out. He also rebuilt the injectors which were clogged and had a shoddy spray pattern. This also contributed to the hard starts.

Glow plugs can fail with no warning. If you pull the plugs and do a resistance check it will tell if a plug is good or not. Specs are online for the Mitsu Plugs.

PM me if you want specifics.
Yeah I joined the Dark Side because the medical plan is top shelf!

Image

alti2d
Posts: 145
Joined: Tue Oct 26, 2010 6:13 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1992 Delica L300
Location: Fort McMurray

Re: ECU problems??? cold start problems TURBO ISSUE?

Postby alti2d » Sat Oct 05, 2013 12:02 pm

As for Calgary mechanics Kirkham automotive might be a place to try. I know they've seen a few delis and perhaps Paj's too. They're on Horton road behind the Southland towers on Southland Dr.
Image

Orionsbelt
Posts: 125
Joined: Wed Feb 02, 2011 1:22 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: '90 Pajero LWB 2.5 TDi
Location: Calgary

Re: ECU problems??? cold start problems TURBO ISSUE?

Postby Orionsbelt » Tue Oct 08, 2013 10:32 am

I 'had' very similar sounding issues with cold starts and would agree with Big-Bird. I will add some findings relative to what I was experiencing.
NOTE: The turbo while maybe requiring a rebuild/new bearings or whatever by the sounds of it - should not be affecting your start-up.

If this is a 2.5 the Injector Pump or IP (if this is what you mean by fuel pump) are pretty solid according to Butch. Not saying they're infallible or subject to 'drying' but pretty solid. The 2.8's are where 'most' of IP front seal issues occur. If it's the IP the result is it continues to smoke with a smell of diesel after the glow plug system has run it's cycle. Stops when the engine finally warms up as you mentioned. However, bad injectors create pretty much the same results...

The glow plugs will only do so much and don't come into play beyond a couple minutes when they finish cycling as you probably know. As Big-Bird mentioned it may also be the injectors requiring cleaning. If you smell diesel/see smoke out the back after start-up - especially after a couple minutes - then the injectors probably require servicing. Even the best working glow plug system will have difficulty starting it up if the injectors are spraying unevenly or also dripping a bit.
I had that done and it was like night and day! No smoke and fired right up except for on the coldest of days here in Calgary where I'd have to hit my manual glow plug system a few more times.

I would have the injectors done.

As a side note...
You may or may not have the 'winter' package which would including a heating element built into where the fuel filter screws into. If your unit has a wire plug going in then you've probably got the winter version. It's designed to turn on when the outside temp drops to 5c or something around there...draws just enough power from the battery to do so and heats the fuel in the little reservoir. In fact you can buy after market one's.

O

Jiustin
Posts: 6
Joined: Thu Sep 06, 2012 11:30 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi pajero v44 4d56
Location: Calgary

Re: ECU problems??? cold start problems TURBO ISSUE?

Postby Jiustin » Mon Mar 10, 2014 9:14 pm

yeah i am looking at getting the injectors rebuilt... who is this butch character at cvi and how do i get ahold of him?...

ive also heard the injector pump on the 4d56 is pretty bullet proof but im pretty sure there may be a micro leak somewhere on the pump( there is alot of dirt and dust that looks damp around the injection pump.

pretty sure i dont have a winter version mine is the single battery style and i dont think there is wires going to the fuel filter box so i think i will install an aftermarket fuel filter wrap heater.

Jiustin
Posts: 6
Joined: Thu Sep 06, 2012 11:30 am
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: Mitsubishi pajero v44 4d56
Location: Calgary

ECU problems??? cold start problems TURBO ISSUE?

Postby Jiustin » Sat Feb 24, 2018 8:25 pm

So turns out the squealing noise I thought might be the turbo ended up being the speedometer cable.

I'm still working away at my cold starting issues. ( I know I'm slow . I purchased an injection pump rebuild kit and I'm going to pull my pump and rebuild it this winter. Hopefully she runs like a top after that.


Return to “Pajero”

Who is online

Users browsing this forum: No registered users and 4 guests