Any Series II L400s on WVO?

WVO filtering, WVO conversion information, biodiesel fuel issues, etc.

Moderator: BCDelica

User avatar
after oil
Posts: 1429
Joined: Mon Feb 11, 2008 7:01 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 cham-reimo poptop L300. 78MB240D
Location: on the road
Location: occupied coast salish territory aka powell river

Any Series II L400s on WVO?

Postby after oil » Sat Mar 24, 2018 10:00 am

I have heard that the injection system on the Series II for some reason maybe can't take WVO. Any thoughts on this?

Ralph in Winnipeg
Posts: 183
Joined: Wed Sep 02, 2015 7:42 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94 Strada
Location: Winnipeg

Any Series II L400s on WVO?

Postby Ralph in Winnipeg » Fri Mar 30, 2018 5:59 pm

Any details as to why? Is it a sensor issue? I have not heard of any issues in those models in particular.

Ralph in Winnipeg

User avatar
after oil
Posts: 1429
Joined: Mon Feb 11, 2008 7:01 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 cham-reimo poptop L300. 78MB240D
Location: on the road
Location: occupied coast salish territory aka powell river

Any Series II L400s on WVO?

Postby after oil » Sat Mar 31, 2018 7:40 am

Haven't hear why, haven't heard of anyone's tried it. Subsequently I've read that the nothing is different at the injection end of the electronic pump so should be fine

Ralph in Winnipeg
Posts: 183
Joined: Wed Sep 02, 2015 7:42 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94 Strada
Location: Winnipeg

Any Series II L400s on WVO?

Postby Ralph in Winnipeg » Sun Apr 01, 2018 3:17 pm

From what I have read on WVO the key is filtering and water removal. I did not want to go to a 2 tank system so I've been using WMO mostly tranny fluid. I can pour it straight in the tank after filtering. Trying to keep it simple!

Ralph in Winnipeg

User avatar
after oil
Posts: 1429
Joined: Mon Feb 11, 2008 7:01 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 cham-reimo poptop L300. 78MB240D
Location: on the road
Location: occupied coast salish territory aka powell river

Any Series II L400s on WVO?

Postby after oil » Sun Apr 01, 2018 5:43 pm

Oh, I know about WVO. Been running it for over a decade now. Done a half dozen conversions at least and driven over 300,000kms on it. I've got a centrifuge. The question here is if the electronic injection pump would have trouble with it.

Ralph in Winnipeg
Posts: 183
Joined: Wed Sep 02, 2015 7:42 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 94 Strada
Location: Winnipeg

Any Series II L400s on WVO?

Postby Ralph in Winnipeg » Tue Apr 03, 2018 5:22 am

Ok, you know more than me :) to quote Ron Swanson. I haven't come across any problems with that injection pump in my reading. Interested in hearing how it goes. I may own something similar in the future.

Ralph in Winnipeg

User avatar
after oil
Posts: 1429
Joined: Mon Feb 11, 2008 7:01 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 cham-reimo poptop L300. 78MB240D
Location: on the road
Location: occupied coast salish territory aka powell river

Any Series II L400s on WVO?

Postby after oil » Tue Apr 03, 2018 8:35 am

Thanks Ralph

poochike
Posts: 111
Joined: Sat Jun 25, 2011 12:52 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 1999 L400 Chamonix Gen2
Location: vancouver
Location: Vancouver

Any Series II L400s on WVO?

Postby poochike » Sun Apr 29, 2018 8:50 pm

after oil wrote:I have heard that the injection system on the Series II for some reason maybe can't take WVO. Any thoughts on this?
I own a 1999 series 2 on WVO with no problems. Ran my L300 on it for around 200,000km before I sold it with a similar set up as my L400. The only difference was my tank on the L300 was heated by the coolant which I wish I had done to my L400 also. Not that I've had any problems, but if any fat ends up in the heated tank it doesn't congial.

Sent from my SM-G920W8 using Tapatalk

User avatar
after oil
Posts: 1429
Joined: Mon Feb 11, 2008 7:01 pm
Member's Photo Album: http://www.delica.ca/Photos/
Vehicle: 92 cham-reimo poptop L300. 78MB240D
Location: on the road
Location: occupied coast salish territory aka powell river

Any Series II L400s on WVO?

Postby after oil » Mon Apr 30, 2018 6:36 am

Good information. Thanks Poochike. My WVO never seems to have any fat in it.


Return to “WVO and Biodiesel”

Who is online

Users browsing this forum: No registered users and 1 guest