L400 Technical

Mitsubishi Delica L400 production commenced in 1994 -- After much anticipation, the L400 arrived on Canadian Soil in 2009!
  • Announcements
    Replies
    Views
    Last post
  • Topics
    Replies
    Views
    Last post
  • CVI Shop Talk For The L400.
    by CVI » Sun May 02, 2010 7:34 pm
    11 Replies
    8243 Views
    Last post by Big-Bird View the latest post
    Mon Aug 26, 2013 4:55 pm
  • L400 Towing Question
    by Lanky » Thu Dec 13, 2018 11:25 am
    2 Replies
    51 Views
    Last post by Lanky View the latest post
    Sat Dec 15, 2018 10:42 am
  • Transfer case cables...?
    by ChuckBlack » Sat Nov 24, 2018 11:13 pm
    0 Replies
    296 Views
    Last post by ChuckBlack View the latest post
    Sat Nov 24, 2018 11:13 pm
  • Where should I get my brakes & oil change done?
    by ilikemax » Thu Oct 27, 2011 3:33 pm
    14 Replies
    1514 Views
    Last post by ealanm View the latest post
    Sat Nov 24, 2018 12:14 am
  • Front seal on fuel pump
    by helibrian » Sat Nov 17, 2018 12:39 pm
    0 Replies
    200 Views
    Last post by helibrian View the latest post
    Sat Nov 17, 2018 12:39 pm
  • Heater core flush
    by mbvalley » Fri Sep 14, 2018 8:41 am
    1 Replies
    299 Views
    Last post by ttrand View the latest post
    Fri Nov 16, 2018 12:58 pm
  • My van rolls when in Park in 4wd
    by agentfridge » Sun Nov 11, 2018 5:49 pm
    1 Replies
    134 Views
    Last post by helibrian View the latest post
    Thu Nov 15, 2018 11:37 pm
  • Possible Tranny Trouble - Shifting Issues
    Attachment(s) by CREGAN » Fri Sep 02, 2011 12:45 pm
    37 Replies
    4835 Views
    Last post by oceanchem View the latest post
    Tue Nov 13, 2018 10:08 pm
  • Block Heater/Lower Rad heater Installation
    by ryanmatthewg » Tue Oct 30, 2018 6:30 pm
    2 Replies
    211 Views
    Last post by jos_mclean View the latest post
    Fri Nov 09, 2018 8:03 pm
  • blown transistor on ECU for glow plug relay
    Attachment(s) by trambo » Thu Nov 01, 2018 11:08 pm
    1 Replies
    150 Views
    Last post by trambo View the latest post
    Thu Nov 01, 2018 11:15 pm
  • Clicking sounds after accelerating
    by Avittery » Thu Nov 01, 2018 2:47 pm
    0 Replies
    235 Views
    Last post by Avittery View the latest post
    Thu Nov 01, 2018 2:47 pm
  • L400 2.8 stalls in cold 2 min after starting fine.
    by Delica_Dave » Mon Feb 06, 2017 11:21 am
    5 Replies
    1085 Views
    Last post by DWESmith View the latest post
    Mon Oct 22, 2018 1:01 pm
  • L400 doesn’t start
    by Lukas80 » Wed Oct 17, 2018 7:20 am
    33 Replies
    1155 Views
    Last post by poochike View the latest post
    Sun Oct 21, 2018 3:39 pm
  • Deli won't start - Starter not engaging...
    by Mr. Flibble » Tue Oct 16, 2018 7:44 pm
    2 Replies
    274 Views
    Last post by Mr. Flibble View the latest post
    Sun Oct 21, 2018 1:30 pm
  • In search of Exploded Fuel Tank Diagram
    by mclarkie » Thu Oct 18, 2018 2:12 pm
    1 Replies
    143 Views
    Last post by poochike View the latest post
    Thu Oct 18, 2018 2:15 pm
  • Accessing A/C low pressure port
    by Mitsuballistic » Mon Aug 06, 2018 7:46 pm
    1 Replies
    348 Views
    Last post by Mr. Flibble View the latest post
    Tue Oct 16, 2018 9:45 pm
  • Interior lights stopped working?
    by Simon84 » Fri Sep 28, 2018 9:19 pm
    3 Replies
    324 Views
    Last post by FalcoColumbarius View the latest post
    Sat Oct 06, 2018 2:57 pm
  • L400 seat question !?!
    Attachment(s) by Migshaw » Mon Oct 01, 2018 7:32 pm
    1 Replies
    294 Views
    Last post by Migshaw View the latest post
    Tue Oct 02, 2018 8:43 am

Return to Board Index

Who is online

Users browsing this forum: No registered users and 8 guests

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum