Search found 34 matches

by mbergerooo
Fri Nov 08, 2019 8:50 am
Forum: L300 Technical
Topic: Strange Battery/Alternator Problem.
Replies: 5
Views: 1526

Strange Battery/Alternator Problem.

My battery is good. My alternator is good. I now noticed that when I turn on my signal light. The flickering warning lights sync with the signal light flashing. It is getting strange. I have no idea what is going on but will take a look inside my dash when I get a chance.
m
by mbergerooo
Tue Oct 29, 2019 7:56 pm
Forum: L300 Technical
Topic: 1993 L300 Pre-Purchase Inspection HELP
Replies: 6
Views: 2084

1993 L300 Pre-Purchase Inspection HELP

This may not be helpful. I bought a VW van once without getting a pre-purchase inspection at a garage. That cost me an additional $3000 because I took the sellers word for it and wanted to save $150. Now I always go for the inspection. Peace of mind I guess. It may still bite you though. Delicas are...
by mbergerooo
Tue Oct 29, 2019 7:48 pm
Forum: L300 Technical
Topic: Strange Battery/Alternator Problem.
Replies: 5
Views: 1526

Strange Battery/Alternator Problem.

The belt tension is good. I tested the voltage on my battery. 12.6v. Then I started the van and turned everything on. Lights, heater, radio. Then my voltage at the battery terminals was over 13v. So I think my charging system is working. A friend is coming over to help me do voltage drop tests and w...
by mbergerooo
Sun Oct 27, 2019 5:09 pm
Forum: L300 Technical
Topic: Strange Battery/Alternator Problem.
Replies: 5
Views: 1526

Strange Battery/Alternator Problem.

I cleaned up the battery compartment but it didn't fix my problem. Any ideas out there? Could it be that my alternator belts slacked off a bit after the long drive?
m
by mbergerooo
Sat Oct 26, 2019 5:48 pm
Forum: L300 Technical
Topic: Strange Battery/Alternator Problem.
Replies: 5
Views: 1526

Strange Battery/Alternator Problem.

Well.I found this.
viewtopic.php?f=6&t=14961&p=116030&hili ... le#p116030
So I will start with really cleaning things up.
m
by mbergerooo
Fri Oct 25, 2019 5:00 pm
Forum: L300 Technical
Topic: Strange Battery/Alternator Problem.
Replies: 5
Views: 1526

Strange Battery/Alternator Problem.

Hi, Something strange is going on in my van. Last week my alternator failed. The dash light did not give me any warning that I was having a problem. Now that I have put about 800kms on the new one. My warning light faintly lights up while at idle. The light will go out when I accelerate. Does anybod...
by mbergerooo
Sun Jan 20, 2019 8:47 pm
Forum: L300 Technical
Topic: Driving BC in the winter.
Replies: 6
Views: 1799

Driving BC in the winter.

Just thought I would let everyone know it can be done. I drove the Coquihalla from Hope to Kamloops and Rogers Pass. Then all the way to Saskatoon. The inclines on the way back west were the hardest parts of the drive. But I read all over the forum about turning off the overdrive and keeping my RPM ...
by mbergerooo
Sun Jan 20, 2019 8:36 pm
Forum: L300 Technical
Topic: Heater Hose Replacement
Replies: 3
Views: 1197

Heater Hose Replacement

Thanks for the reply. I still have not done it. Should get to it soon. I was supposed to get them changed before the road trip but just brought them along. 3,300km round trip and went great anyways.
m
by mbergerooo
Fri Dec 07, 2018 11:14 am
Forum: L300 Technical
Topic: Heater Hose Replacement
Replies: 3
Views: 1197

Heater Hose Replacement

Hi,
I am about to replace the two heater hoses behind the motor. Do I have to drain the coolant before I remove them? Is silicon spray a good lubricant for getting the new hoses on?
Thanks,
m
by mbergerooo
Wed Oct 03, 2018 7:35 am
Forum: L300 Technical
Topic: Rear Lights and Dash quit.
Replies: 11
Views: 3246

Rear Lights and Dash quit.

Yup. Flasher relay connections? I wiggled all the wires and boxes behind the glove box and everything works now.
m
by mbergerooo
Sun Sep 23, 2018 6:01 pm
Forum: L300 Technical
Topic: Rear Lights and Dash quit.
Replies: 11
Views: 3246

Rear Lights and Dash quit.

I think my flasher relay has quit. My signal lights still don't work after a good cleaning in the combo switch. But my hazards still work. Does anybody know if I am on the right trail? My fuses are ok.
m
by mbergerooo
Sun Sep 23, 2018 3:52 pm
Forum: L300 Technical
Topic: Rear Lights and Dash quit.
Replies: 11
Views: 3246

Rear Lights and Dash quit.

Also I took the spring loaded parts of the switch apart and pulled the springs a bit. Making everything push a bit harder against one another. It seems to me that these sliders want to take a break after 25 years. So I just tried to bend things a bit this way and that to get an even contact in there...
by mbergerooo
Sun Sep 23, 2018 3:48 pm
Forum: L300 Technical
Topic: Rear Lights and Dash quit.
Replies: 11
Views: 3246

Rear Lights and Dash quit.

Ok! So a friend helped me out and found that despite my cleaning. They were not clean enough. We sanded the contact points a bit with sandpaper and it all works again! Well my signal lights are not working yet but I will go back into that side now and do the same. m
by mbergerooo
Sat Sep 22, 2018 6:44 pm
Forum: L300 Technical
Topic: Rear Lights and Dash quit.
Replies: 11
Views: 3246

Rear Lights and Dash quit.

And now my signal lights quit on me.
m

Go to advanced search